Docling Core vulnerabilities

2 vulnerabilities

Known vulnerabilities in Docling Core, newest first, with CVSS severity, EPSS, KEV listings, ransomware use and the affected versions.

PrioritiseCVE-2026-44023docling-project · docling-core +2 moreDocling Core has unsafe remote filename resolutionDocling Core defines core data types and transformations for the document processing application Docling. In versions 1.5.0 and above, prior to 2.74.1, docling-core did not sufficiently restrict remote request destinations and could resolve a server-provided Content-Disposition to a local path in an unsafe manner. In applications that accept untrusted URLs, this could allow SSRF attacks targeting local files outside the user-defined cache directory. This issue has been fixed in version 2.74.1.CVSS8.6HighEPSS0.43%PrioritiseCVE-2026-24009docling-project · docling-core +2 moreDocling Core vulnerable to Remote Code Execution via unsafe PyYAML usageDocling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.CVSS9.8CriticalEPSS1.53%