Gnu Ncurses vulnerabilities
2 vulnerabilities
Known vulnerabilities in Gnu Ncurses, newest first, with CVSS severity, EPSS, KEV listings, ransomware use and the affected versions.
PrioritiseCVE-2025-69720gnu · ncurses +29 moregnu ncursesThe infocmp command-line tool in ncurses before 6.5-20251213 has a stack-based buffer overflow in analyze_string in progs/infocmp.c.CVSS7.8HighEPSS0.46%RoutineCVE-2025-6141gnu · ncurses +2 moreGNU ncurses parse_entry.c postprocess_termcap stack-based overflowA vulnerability has been found in GNU ncurses up to 6.5-20250322 and classified as problematic. This vulnerability affects the function postprocess_termcap of the file tinfo/parse_entry.c. The manipulation leads to stack-based buffer overflow. The attack needs to be approached locally. Upgrading to version 6.5-20250329 is able to address this issue. It is recommended to upgrade the affected component.CVSS4.8MediumEPSS0.20%