Google Brotli vulnerabilities
2 vulnerabilities
Known vulnerabilities in Google Brotli, newest first, with CVSS severity, EPSS, KEV listings, ransomware use and the affected versions.
Act nowCVE-2026-111497Google · Brotli +399 moreGoogle Brotli Unchecked Return Value VulnerabilityA buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.
Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.CVSS9.8CriticalKEVEPSS82.64%PrioritiseCVE-2020-36846timlegge · io::compress::brotli +160 moreIO::Compress::Brotli versions prior to 0.007 for Perl have an integer overflow in the bundled Brotli C libraryA buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.CVSS9.8CriticalEPSS0.66%