Oracle Payment Interface vulnerabilities

3 vulnerabilities

Known vulnerabilities in Oracle Payment Interface, newest first, with CVSS severity, EPSS, KEV listings, ransomware use and the affected versions.

RoutineCVE-2021-45105apache software foundation · apache log4j2 +125 moreApache Log4j2 does not always protect from infinite recursion in lookup evaluationApache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3 and 2.3.1) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0, 2.12.3, and 2.3.1.CVSS5.9MediumEPSS100.00%PrioritiseCVE-2021-42340apache software foundation · apache tomcat +23 moreDoS via memory leak with WebSocket connectionsThe fix for bug 63362 present in Apache Tomcat 10.1.0-M1 to 10.1.0-M5, 10.0.0-M1 to 10.0.11, 9.0.40 to 9.0.53 and 8.5.60 to 8.5.71 introduced a memory leak. The object introduced to collect metrics for HTTP upgrade connections was not released for WebSocket connections once the connection was closed. This created a memory leak that, over time, could lead to a denial of service via an OutOfMemoryError.CVSS7.5HighEPSS11.80%RoutineCVE-2017-10069oracle corporation · payment gateway services +1 moreoracle corporation payment gateway servicesVulnerability in the Oracle Payment Interface component of Oracle Hospitality Applications (subcomponent: Core). The supported version that is affected is 6.1.1. Difficult to exploit vulnerability allows low privileged attacker with network access via HTTP to compromise Oracle Payment Interface. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all Oracle Payment Interface accessible data. CVSS 3.0 Base Score 5.3 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N).CVSS5.3MediumEPSS1.48%