Zopefoundation Products.Pluggableauthservice vulnerabilities
2 vulnerabilities
Known vulnerabilities in Zopefoundation Products.Pluggableauthservice, newest first, with CVSS severity, EPSS, KEV listings, ransomware use and the affected versions.
RoutineCVE-2021-21337zopefoundation · products.pluggableauthservice +2 moreURL Redirection to Untrusted Site ('Open Redirect') in Products.PluggableAuthServiceProducts.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an open redirect vulnerability. A maliciously crafted link to the login form and login functionality could redirect the browser to a different website. The problem has been fixed in version 2.6.1. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to `2.6.1` and re-run the buildout, or if you used `pip` simply do `pip install "Products.PluggableAuthService>=2.6.1".CVSS6.1MediumEPSS8.44%RoutineCVE-2021-21336zopefoundation · products.pluggableauthservice +3 moreExposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManagerProducts.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.CVSS6.5MediumEPSS1.50%