8.6

CVE-2016-10142: ietf ipv6 DEPRECATED: Code

Modified
AliasesUBUNTU-CVE-2016-10142
Published 14-01-2017Last modified 06-08-2024

Vulnerability summary

CVE-2016-10142 is a high (CVSS 8.6) DEPRECATED: Code vulnerability in ietf ipv6. EPSS estimates a 2.80% chance of exploitation in the next 30 days, higher than 86.5% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 8.6 (NVD); no exploitation reported by the 5 checked sources; EPSS 3% (FIRST, 04-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
8.6/10
010
High · v3.0 (NVD)
EPSS score
2.80%
0%100%
Low · +0.05 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 1

Timeline

  1. 14-01-2017
    PublishedVulnerability first disclosed.
  2. 06-08-2024
    Last modifiedVulnerability information updated.

Description

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.

CVSS metrics

3 scores · 2 sources · 2 versions

EPSS trend

Probability

2.80%

Chance of exploitation in the next 30 days

Percentile

87%

Versus all other CVEs

30-day change

Increase +0.05 pp

From 2.75% on 05-10-2026

05-10-202604-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Ubuntu18 products
  • linux< 3.13.0-51.84
  • linux-azureAll versions (No fix recorded)
  • linux-azure-6.11All versions (No fix recorded)
  • linux-azure-fdeAll versions (No fix recorded)
  • linux-azure-fde-5.15All versions (No fix recorded)
Ietf1 product

2 vendors · 19 products

References

11 links
Show all 11 references