CVE-2017-0899: debian debian_linux
Vulnerability summary
CVE-2017-0899 is a critical (CVSS 9.8) vulnerability in debian debian_linux. EPSS estimates a 11.10% chance of exploitation in the next 30 days, higher than 95.9% of scored vulnerabilities. 1 public exploit is recorded.
Public exploit (reference, Date unknown)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 10 · Related 3Timeline
- 31-08-2017PublishedVulnerability first disclosed.
- 17-09-2024Last modifiedVulnerability information updated.
Description
RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.
CVSS metrics
6 scores · 5 sources · 2 versions- OSV · AlpineEcosystem advisory · calculated9.8CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · UbuntuEcosystem advisory · calculated9.8CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · DebianEcosystem advisory · calculated9.8CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · RubygemsEcosystem advisory · calculated9.8CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
11.10%
Chance of exploitation in the next 30 days
Percentile
96%
Versus all other CVEs
30-day change
No change 0.00 pp
From 11.10% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundExploit Reference (hackerone.com)
Maturity: unknown
Weaknesses
CWE · root cause- CWE-150Improper Neutralization of Escape, Meta, or Control SequencesThe product receives input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could be interpreted as escape, meta, or control character sequences when they are sent to a downstream component.
- CWE-94Improper Control of Generation of CodeThe product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the syntax or behavior of the intended code segment.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Redhat6 products
- enterprise_linux_desktop7.0
- enterprise_linux_server7.0
- enterprise_linux_server_aus7.4 | 7.6
- enterprise_linux_server_eus7.4 | 7.5 | 7.6
- enterprise_linux_server_tus7.4 | 7.6
Ubuntu3 products
- jrubyAll versions (No fix recorded)
- ruby1.9.1< 1.9.3.484-2ubuntu1.5
- ruby2.3< 2.3.1-2~16.04.6
Alpine2 products
- ruby< 2.4.2-r0 | < 2.2.8-r0 | < 2.3.5-r0
- ruby2.2< 2.2.8-r0
Debian2 products
- rubygems< 3.2.0~rc.1-1
- debian_linuxEOL8.0 | 9.0
RubyGems2 products
- rubygems-update< 2.6.13
- rubygems≤ 2.6.12
Hackerone1 product
- rubygemsVersions before 2.6.13
6 vendors · 16 products
References
24 links- github.com/rubygems/rubygems/commit/1bcbc7fe637b03145401ec9c094066285934a7f1X Refsource MISCPatchThird Party AdvisoryWEB
- github.com/rubygems/rubygems/commit/ef0aa611effb5f54d40c7fba6e8235eb43c5a491X Refsource MISCPatchThird Party AdvisoryWEB
- lists.debian.org/debian-lts-announce/2018/07/msg00012.htmlMailing ListX Refsource MLISTThird Party AdvisoryWEB
Show all 24 references
- github.com/rubygems/rubygemsPACKAGE