CVE-2017-0901: canonical ubuntu_linux
Vulnerability summary
CVE-2017-0901 is a high (CVSS 7.5) vulnerability in canonical ubuntu_linux. EPSS estimates a 29.44% chance of exploitation in the next 30 days, higher than 98.1% of scored vulnerabilities. 2 public exploits are recorded.
Weaponized exploit (exploit-database, 04-09-2017)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 13 · Related 4Timeline
- 31-08-2017PublishedVulnerability first disclosed.
- 16-09-2024Last modifiedVulnerability information updated.
Description
RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.
CVSS metrics
6 scores · 5 sources · 2 versions- OSV · AlpineEcosystem advisory · calculated7.5HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · RubygemsEcosystem advisory · calculated7.5HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS trend
Probability
29.44%
Chance of exploitation in the next 30 days
Percentile
98%
Versus all other CVEs
30-day change
Increase +0.71 pp
From 28.74% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
2 foundExploit Reference (hackerone.com)
Maturity: unknown
RubyGems < 2.6.13 - Arbitrary File Overwrite
Maturity: weaponized
Weaknesses
CWE · root cause- CWE-22Improper Limitation of a Pathname to a Restricted DirectoryThe product uses external input to construct a pathname that is intended to identify a file or directory that is located underneath a restricted parent directory, but the product does not properly neutralize special elements within the pathname that can cause the pathname to resolve to a location that is outside of the restricted directory.
- CWE-20Improper Input ValidationThe product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Redhat6 products
- enterprise_linux_desktop7.0
- enterprise_linux_server7.0
- enterprise_linux_server_aus7.4 | 7.6
- enterprise_linux_server_eus7.4 | 7.5 | 7.6
- enterprise_linux_server_tus7.4 | 7.6
Ubuntu4 products
- jrubyAll versions (No fix recorded)
- ruby1.9.1< 1.9.3.484-2ubuntu1.5
- ruby2.0< 2.0.0.484-1ubuntu2.10
- ruby2.3< 2.3.1-2~16.04.6
Alpine2 products
- ruby< 2.4.2-r0 | < 2.2.8-r0 | < 2.3.5-r0
- ruby2.2< 2.2.8-r0
Debian2 products
- rubygems< 3.2.0~rc.1-1
- debian_linuxEOL8.0 | 9.0
RubyGems2 products
- rubygems-update< 2.6.13
- rubygems≤ 2.6.12
Canonical1 product
- ubuntu_linuxEOL14.04 | 16.04 | 17.10
Hackerone1 product
- rubygemsVersions before 2.6.13
7 vendors · 18 products
References
30 links- github.com/rubygems/rubygems/commit/ad5c0a53a86ca5b218c7976765c0365b91d22cb2X Refsource MISCPatchThird Party AdvisoryWEB
Show all 30 references
- lists.debian.org/debian-lts-announce/2018/07/msg00012.htmlMailing ListX Refsource MLISTThird Party AdvisoryWEB
- github.com/rubygems/rubygemsPACKAGE