CVE-2017-14589: atlassian bamboo Improper Input Validation
Vulnerability summary
CVE-2017-14589 is a critical (CVSS 9.6) Improper Input Validation vulnerability in atlassian bamboo. EPSS estimates a 1.87% chance of exploitation in the next 30 days, higher than 79.4% of scored vulnerabilities.
Severe, CVSS 9.6 (NVD); no exploitation reported by the 5 checked sources; EPSS 2% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Timeline
- 13-12-2017PublishedVulnerability first disclosed.
- 16-09-2024Last modifiedVulnerability information updated.
Description
It was possible for double OGNL evaluation in FreeMarker templates through Struts FreeMarker tags to occur. An attacker who has restricted administration rights to Bamboo or who hosts a website that a Bamboo administrator visits, is able to exploit this vulnerability to execute Java code of their choice on systems that run a vulnerable version of Bamboo. All versions of Bamboo before 6.1.6 (the fixed version for 6.1.x) and from 6.2.0 before 6.2.5 (the fixed version for 6.2.x) are affected by this vulnerability.
CVSS metrics
2 scores · 1 source · 2 versionsEPSS trend
Probability
1.87%
Chance of exploitation in the next 30 days
Percentile
79%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.87% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Atlassian1 product
- bamboo< 6.1.6 (the fixed version for 6.1.x) | from 6.2.0 before 6.2.5 (the fixed version for 6.2.x) | < 6.1.6 | ≥ 6.2.0, < 6.2.5
1 vendor · 1 product
References
3 links- confluence.atlassian.com/bamboo/bamboo-security-advisory-2017-12-13-939939816.htmlX Refsource CONFIRMVendor Advisory