CVE-2018-11751: puppet puppet_server Improper Certificate Validation
Vulnerability summary
CVE-2018-11751 is a medium (CVSS 5.4) Improper Certificate Validation vulnerability in puppet puppet_server. EPSS estimates a 0.61% chance of exploitation in the next 30 days, higher than 49.1% of scored vulnerabilities.
Not severe (CVSS 5.4, adjacent network); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1Timeline
- 16-12-2019PublishedVulnerability first disclosed.
- 05-08-2024Last modifiedVulnerability information updated.
Description
Previous versions of Puppet Agent didn't verify the peer in the SSL connection prior to downloading the CRL. This issue is resolved in Puppet Agent 6.4.0.
CVSS metrics
2 scores · 1 source · 2 versionsEPSS trend
Probability
0.61%
Chance of exploitation in the next 30 days
Percentile
49%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.61% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: adjacent network, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Puppet1 product
- puppet_server≥ 6.0.0, < 6.4.0
1 vendor · 1 product