CVE-2018-5224: atlassian bamboo Improper Input Validation
Vulnerability summary
CVE-2018-5224 is a high (CVSS 9.0) Improper Input Validation vulnerability in atlassian bamboo. EPSS estimates a 2.67% chance of exploitation in the next 30 days, higher than 85.7% of scored vulnerabilities.
Not severe (CVSS 8.8, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 29-03-2018PublishedVulnerability first disclosed.
- 16-09-2024Last modifiedVulnerability information updated.
Description
Bamboo did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan in Bamboo that has a non-linked Mercurial repository, or create a plan in Bamboo either globally or in a project using Bamboo Specs can can execute code of their choice on systems that run a vulnerable version of Bamboo on the Windows operating system. All versions of Bamboo starting with 2.7.0 before 6.3.3 (the fixed version for 6.3.x) and from version 6.4.0 before 6.4.1 (the fixed version for 6.4.x) running on the Windows operating system are affected by this vulnerability.
CVSS metrics
2 scores · 1 source · 2 versionsEPSS trend
Probability
2.67%
Chance of exploitation in the next 30 days
Percentile
86%
Versus all other CVEs
30-day change
No change 0.00 pp
From 2.67% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Atlassian1 product
- bamboo≥ 2.7.1, < unspecified | ≥ unspecified, < 6.3.3 | ≥ 6.4.0, < unspecified | ≥ unspecified, < 6.4.1 | ≥ 2.7.0, < 6.3.3 | ≥ 6.4.0, < 6.4.1
1 vendor · 1 product