CVE-2019-10156: debian debian_linux
Vulnerability summary
CVE-2019-10156 is a medium (CVSS 5.5) vulnerability in debian debian_linux. EPSS estimates a 1.76% chance of exploitation in the next 30 days, higher than 78% of scored vulnerabilities.
Not severe (CVSS 4.6, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 13 · Related 8Timeline
- 30-07-2019PublishedVulnerability first disclosed.
- 04-08-2024Last modifiedVulnerability information updated.
Description
A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.
CVSS metrics
11 scores · 7 sources · 4 versions- OSV · AlpineEcosystem advisory · calculated5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- OSV · PypiEcosystem advisory · calculated5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- OSV · UbuntuEcosystem advisory · calculated5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- OSV · DebianEcosystem advisory · calculated5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- NVDNIST4.6MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- OSV · Red hatEcosystem advisory · calculated4.6MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- OSV · UbuntuEcosystem advisory · calculated5.4MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NDiffers
EPSS trend
Probability
1.76%
Chance of exploitation in the next 30 days
Percentile
78%
Versus all other CVEs
30-day change
Decrease -0.01 pp
From 1.77% on 05-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.
Mageia3 products
- ansible< 2.7.12-1.mga6
- python-jmespath< 0.9.4-1.2.mga6
- ansible< 2.7.12-1.mga7
Redhat3 products
Alpine2 products
- ansible≥ 2.7.0, < 2.8.2-r0 | ≥ 2.7.0, < 2.6.18-r0
- ansible-base< 2.8.2-r0
Debian2 products
- ansible< 2.8.3+dfsg-1
- debian_linuxEOL8.0 | 9.0
PyPI1 product
- ansible< 2.6.18 | ≥ 2.7.0a1, < 2.7.12 | ≥ 2.8.0a1, < 2.8.2 | ≥ 2.8.0, < 2.8.2
Red hat1 product
- ansiblefixed in 2.6.18 | fixed in 2.7.12 | fixed in 2.8.2
Ubuntu1 product
- ansible< 2.5.1+dfsg-1ubuntu0.1
7 vendors · 13 products
References
39 links- bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10156X Refsource CONFIRMIssue TrackingVendor AdvisoryWEBREPORT
- lists.debian.org/debian-lts-announce/2019/09/msg00016.htmlMailing ListX Refsource MLISTVendor AdvisoryWEB
- lists.debian.org/debian-lts-announce/2021/01/msg00023.htmlMailing ListX Refsource MLISTThird Party AdvisoryWEB
Show all 39 references
- github.com/ansible/ansiblePACKAGE