CVE-2019-12472: mediawiki
Vulnerability summary
CVE-2019-12472 is a high (CVSS 7.5) vulnerability in mediawiki. EPSS estimates a 1.32% chance of exploitation in the next 30 days, higher than 71% of scored vulnerabilities.
Severe, CVSS 7.5 (NVD); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 04-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 2Timeline
- 10-07-2019PublishedVulnerability first disclosed.
- 04-08-2024Last modifiedVulnerability information updated.
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
CVSS metrics
4 scores · 3 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS trend
Probability
1.32%
Chance of exploitation in the next 30 days
Percentile
71%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.32% on 05-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeNo weakness data has been published for this record.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Debian1 product
- mediawiki< 1:1.31.2-1
Mediawiki1 product
- mediawiki≥ 1.18.0, < 1.27.6 | ≥ 1.30.0, < 1.30.2 | ≥ 1.31.0, < 1.31.2 | ≥ 1.32.0, < 1.32.2
Ubuntu1 product
- mediawikiAll versions (No fix recorded)
3 vendors · 3 products
References
5 links- lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.htmlX Refsource CONFIRMPatchThird Party AdvisoryREPORT