CVE-2019-12474: debian debian_linux
Vulnerability summary
CVE-2019-12474 is a high (CVSS 7.5) vulnerability in debian debian_linux. EPSS estimates a 2.04% chance of exploitation in the next 30 days, higher than 81.2% of scored vulnerabilities.
Severe, CVSS 7.5 (NVD); no exploitation reported by the 5 checked sources; EPSS 2% (FIRST, 04-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 2Timeline
- 10-07-2019PublishedVulnerability first disclosed.
- 04-08-2024Last modifiedVulnerability information updated.
Description
Wikimedia MediaWiki 1.23.0 through 1.32.1 has an information leak. Privileged API responses that include whether a recent change has been patrolled may be cached publicly. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
CVSS metrics
4 scores · 3 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS trend
Probability
2.04%
Chance of exploitation in the next 30 days
Percentile
81%
Versus all other CVEs
30-day change
No change 0.00 pp
From 2.04% on 05-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeNo weakness data has been published for this record.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Debian2 products
- mediawiki< 1:1.31.2-1
- debian_linuxEOL9.0
Mediawiki1 product
- mediawiki≥ 1.23.0, < 1.27.6 | ≥ 1.30.0, < 1.30.2 | ≥ 1.31.0, < 1.31.2 | ≥ 1.32.0, < 1.32.2
Ubuntu1 product
- mediawikiAll versions (No fix recorded)
3 vendors · 4 products
References
7 links- lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.htmlX Refsource CONFIRMPatchThird Party AdvisoryREPORT