7.4

CVE-2019-1543: ChaCha20-Poly1305 with long nonces

Modified
AliasesALPINE-CVE-2019-1543SUSE-SU-2019:0678-1SUSE-SU-2019:0787-1
Published 06-03-2019Last modified 02-11-2026

Vulnerability summary

CVE-2019-1543 is a high (CVSS 7.4) vulnerability in openssl. EPSS estimates a 5.70% chance of exploitation in the next 30 days, higher than 93% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.4 (NVD); no exploitation reported by the 5 checked sources; EPSS 6% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.4/10
010
High · v3.0 (NVD)
EPSS score
5.70%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 5 · Related 2

Timeline

  1. 06-03-2019
    PublishedVulnerability first disclosed.
  2. 02-11-2026
    Last modifiedVulnerability information updated.

Description

ChaCha20-Poly1305 is an AEAD cipher, and requires a unique nonce input for every encryption operation. RFC 7539 specifies that the nonce value (IV) should be 96 bits (12 bytes). OpenSSL allows a variable nonce length and front pads the nonce with 0 bytes if it is less than 12 bytes. However it also incorrectly allows a nonce to be set of up to 16 bytes. In this case only the last 12 bytes are significant and any additional leading bytes are ignored. It is a requirement of using this cipher that nonce values are unique. Messages encrypted using a reused nonce value are susceptible to serious confidentiality and integrity attacks. If an application changes the default nonce length to be longer than 12 bytes and then makes a change to the leading bytes of the nonce expecting the new value to be a new unique nonce then such an application could inadvertently encrypt messages with a reused nonce. Additionally the ignored bytes in a long nonce are not covered by the integrity guarantee of this cipher. Any application that relies on the integrity of these ignored leading bytes of a long nonce may be further affected. Any OpenSSL internal use of this cipher, including in SSL/TLS, is safe because no such use sets such a long nonce value. However user applications that use this cipher directly and set a non-default nonce length to be longer than 12 bytes may be vulnerable. OpenSSL versions 1.1.1 and 1.1.0 are affected by this issue. Due to the limited scope of affected deployments this has been assessed as low severity and therefore we are not creating new releases at this time. Fixed in OpenSSL 1.1.1c (Affected 1.1.1-1.1.1b). Fixed in OpenSSL 1.1.0k (Affected 1.1.0-1.1.0j).

CVSS metrics

5 scores · 4 sources · 2 versions

EPSS trend

Probability

5.70%

Chance of exploitation in the next 30 days

Percentile

93%

Versus all other CVEs

30-day change

No change 0.00 pp

From 5.70% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Suse5 products
  • openssl-1_1&distro=SUSE Linux Enterprise Desktop 12 SP4< 1.1.1-2.9.1
  • openssl-1_1&distro=SUSE Linux Enterprise Module for Basesystem 15< 1.1.0i-4.21.1
  • openssl-1_1&distro=SUSE Linux Enterprise Server 12 SP4< 1.1.1-2.9.1
  • openssl-1_1&distro=SUSE Linux Enterprise Server for SAP Applications 12 SP4< 1.1.1-2.9.1
  • openssl-1_1&distro=SUSE Linux Enterprise Software Development Kit 12 SP4< 1.1.1-2.9.1
Alpine4 products
  • file< 5.36-r0
  • openssl≥ 1.1.0, < 1.1.1b-r1
  • openssl1.1-compat< 1.1.1b-r1
  • openssl3< 1.1.1b-r1
Debian1 product
  • openssl< 1.1.0k-1~deb9u1 | < 1.1.1c-1
Openssl1 product
  • opensslFixed in OpenSSL 1.1.1c (Affected 1.1.1-1.1.1b) | Fixed in OpenSSL 1.1.0k (Affected 1.1.0-1.1.0j) | ≥ 1.1.0, ≤ 1.1.0j | ≥ 1.1.1, ≤ 1.1.1b
Opensuse1 product
  • openssl-1_1&distro=openSUSE Leap 15.0< 1.1.0i-lp150.3.22.3
Ubuntu1 product
  • openssl< 1.1.1-1ubuntu2.1~18.04.2

6 vendors · 13 products

References

24 links
Show all 24 references