CVE-2019-8322: debian debian_linux
Vulnerability summary
CVE-2019-8322 is a high (CVSS 7.5) vulnerability in debian debian_linux. EPSS estimates a 3.28% chance of exploitation in the next 30 days, higher than 88.4% of scored vulnerabilities.
Severe, CVSS 7.5 (NVD); no exploitation reported by the 5 checked sources; EPSS 3% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 16 · Related 4Timeline
- 17-06-2019PublishedVulnerability first disclosed.
- 04-08-2024Last modifiedVulnerability information updated.
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. The gem owner command outputs the contents of the API response directly to stdout. Therefore, if the response is crafted, escape sequence injection may occur.
CVSS metrics
6 scores · 5 sources · 2 versions- OSV · AlpineEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · RubygemsEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS trend
Probability
3.28%
Chance of exploitation in the next 30 days
Percentile
88%
Versus all other CVEs
30-day change
No change 0.00 pp
From 3.28% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Ubuntu5 products
- jruby< 1.5.6-9+deb8u2build0.14.04.1~esm2 | All versions (No fix recorded)
- ruby1.9.1< 1.9.3.484-2ubuntu1.14
- ruby2.0< 2.0.0.484-1ubuntu2.13
- ruby2.3< 2.3.1-2~16.04.12
- ruby2.5< 2.5.1-1ubuntu1.2
Debian3 products
- jruby< 9.1.17.0-3
- rubygems< 3.2.0~rc.1-1
- debian_linuxEOL9.0
RubyGems2 products
- rubygems-update≥ 2.6.0, < 2.7.9 | ≥ 3.0.0, < 3.0.2
- rubygems≥ 2.6.0, ≤ 3.0.2
Alpine1 product
- ruby< 2.4.6-r0 | < 2.5.5-r0
Opensuse1 product
- leapEOL15.0 | 15.1
5 vendors · 12 products
References
14 links- lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.htmlVendor AdvisoryX Refsource SUSEWEBMailing ListThird Party Advisory
- lists.debian.org/debian-lts-announce/2020/08/msg00027.htmlMailing ListX Refsource MLISTWEBThird Party Advisory