CVE-2020-15157: containerd can be coerced into leaking credentials during image pull
Vulnerability summary
CVE-2020-15157 is a medium (CVSS 6.1) Insufficiently Protected Credentials vulnerability in canonical ubuntu_linux. EPSS estimates a 2.30% chance of exploitation in the next 30 days, higher than 83.3% of scored vulnerabilities.
Not severe (CVSS 6.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 8 · Related 6Timeline
- 16-10-2020PublishedVulnerability first disclosed.
- 04-08-2024Last modifiedVulnerability information updated.
Description
In containerd (an industry-standard container runtime) before version 1.2.14 there is a credential leaking vulnerability. If a container image manifest in the OCI Image format or Docker Image V2 Schema 2 format includes a URL for the location of a specific image layer (otherwise known as a “foreign layer”), the default containerd resolver will follow that URL to attempt to download it. In v1.2.x but not 1.3.0 or later, the default containerd resolver will provide its authentication credentials if the server where the URL is located presents an HTTP 401 status code along with registry-specific HTTP headers. If an attacker publishes a public image with a manifest that directs one of the layers to be fetched from a web server they control and they trick a user or system into pulling the image, they can obtain the credentials used for pulling that image. In some cases, this may be the user's username and password for the registry. In other cases, this may be the credentials attached to the cloud virtual instance which can grant access to other cloud resources in the account. The default containerd resolver is used by the cri-containerd plugin (which can be used by Kubernetes), the ctr development tool, and other client programs that have explicitly linked against it. This vulnerability has been fixed in containerd 1.2.14. containerd 1.3 and later are not affected. If you are using containerd 1.3 or later, you are not affected. If you are using cri-containerd in the 1.2 series or prior, you should ensure you only pull images from trusted sources. Other container runtimes built on top of containerd but not using the default resolver (such as Docker) are not affected.
CVSS metrics
6 scores · 5 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated6.1MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
- OSV · DebianEcosystem advisory · calculated6.1MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
- OSV · GoEcosystem advisory · calculated6.1MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
- NVDNIST6.1MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS trend
Probability
2.30%
Chance of exploitation in the next 30 days
Percentile
83%
Versus all other CVEs
30-day change
No change 0.00 pp
From 2.30% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Debian3 products
- containerd< 1.3.2~ds1-2
- docker.io< 19.03.13+dfsg2-1
- debian_linuxEOL10.0
Ubuntu2 products
- containerd< 1.2.6-0ubuntu1~16.04.4
- docker.io< 18.09.7-0ubuntu1~16.04.6 | < 19.03.6-0ubuntu1~18.04.2 | < 19.03.8-0ubuntu1.20.04.1
Canonical1 product
- ubuntu_linuxEOL16.04 | 18.04 | 20.04
Containerd1 product
- containerd< 1.2.14
Github.com/containerd1 product
- containerd< 1.2.14
Linuxfoundation1 product
- containerdEOL≥ 1.2.0, < 1.2.14 | 1.3.0 | 1.3.0:beta0 | 1.3.0:beta1 | 1.3.0:beta2 | 1.3.0:rc0 | 1.3.0:rc1 | 1.3.0:rc2 | 1.3.0:rc3
Mageia1 product
- docker< 18.09.9-1.2.mga7
7 vendors · 10 products
References
19 links- github.com/containerd/containerd/security/advisories/GHSA-742w-89gc-8m9cX Refsource CONFIRMWEBAdvisoryThird Party Advisory