CVE-2020-15704: pppd arbitrary file read information disclosure vulnerability
Vulnerability summary
CVE-2020-15704 is a medium (CVSS 5.5) vulnerability in canonical ppp. EPSS estimates a 0.36% chance of exploitation in the next 30 days, higher than 30.3% of scored vulnerabilities.
Not severe (CVSS 5.5, local access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 31-08-2020PublishedVulnerability first disclosed.
- 17-09-2024Last modifiedVulnerability information updated.
Description
The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.
CVSS metrics
4 scores · 3 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated5.5MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- NVDNIST5.5MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS trend
Probability
0.36%
Chance of exploitation in the next 30 days
Percentile
30%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.36% on 05-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-200Exposure of Sensitive Information to an Unauthorized ActorThe product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
- CWE-20Improper Input ValidationThe product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
Affected systems
Known conditions: local access, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Canonical1 product
- ppp≥ 2.4.5, < 2.4.5-5ubuntu1.4 | ≥ 2.4.7, < 2.4.7-1+2ubuntu1.16.04.3 | < 2.4.7-1\+ubuntu1.16.04.3 | < 2.4.7-2\+2ubuntu1.3 | < 2.4.7-2\+4.1ubuntu5.1 | < 2.4.5-5ubuntu1.4 | < 2.4.5-5.1ubuntu2.3\+esm2
Ubuntu1 product
- ppp< 2.4.7-1+2ubuntu1.16.04.3 | < 2.4.7-2+2ubuntu1.3 | < 2.4.7-2+4.1ubuntu5.1 | < 2.4.5-5.1ubuntu2.3+esm2
2 vendors · 2 products