5.9

CVE-2021-21409: Possible request smuggling in HTTP/2 due missing validation of content-length

Modified
AliasesUBUNTU-CVE-2021-21409DEBIAN-CVE-2021-21409CGA-2gv8-v5wf-vvp4
Published 30-03-2021Last modified 08-10-2026

Vulnerability summary

CVE-2021-21409 is a medium (CVSS 5.9) vulnerability in debian debian_linux. EPSS estimates a 4.93% chance of exploitation in the next 30 days, higher than 92.1% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.9, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
5.9/10
010
Medium · v3.1 (CVE.org)
EPSS score
4.93%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 11 · Related 6

Timeline

  1. 30-03-2021
    PublishedVulnerability first disclosed.
  2. 08-10-2026
    Last modifiedVulnerability information updated.

Description

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.61.Final there is a vulnerability that enables request smuggling. The content-length header is not correctly validated if the request only uses a single Http2HeaderFrame with the endStream set to to true. This could lead to request smuggling if the request is proxied to a remote peer and translated to HTTP/1.1. This is a followup of GHSA-wm47-8v5p-wjpj/CVE-2021-21295 which did miss to fix this one case. This was fixed as part of 4.1.61.Final.

CVSS metrics

8 scores · 7 sources · 2 versions

EPSS trend

Probability

4.93%

Chance of exploitation in the next 30 days

Percentile

92%

Versus all other CVEs

30-day change

No change 0.00 pp

From 4.93% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Oracle13 products
Chainguard4 products
  • druidAll versions (No fix recorded)
  • hadoop-fips-3.3.6All versions (No fix recorded)
  • hadoop-fips-3.4.2All versions (No fix recorded)
  • hadoop-fips-3.5All versions (No fix recorded)
Debian2 products
Io.netty2 products
  • nettyAll versions (No fix recorded)
  • netty-codec-http2≥ 4.0.0, < 4.1.61.Final
Netapp2 products
Netty1 product
  • netty< 4.1.61.Final | < 4.1.61
Opensuse1 product
  • netty&distro=openSUSE Leap 15.3< 4.1.75-150200.4.9.1
Org.jboss.netty1 product
  • nettyAll versions (No fix recorded)
Quarkus1 product
Ubuntu1 product
  • nettyAll versions (No fix recorded) | < 1:4.0.34-1ubuntu0.1~esm1 | < 1:4.1.7-4ubuntu0.1+esm2 | < 1:4.1.45-1ubuntu0.1~esm1 | < 1:4.1.48-4+deb11u1build0.22.04.1
Wolfi1 product
  • druidAll versions (No fix recorded)

11 vendors · 29 products

References

118 links
Show all 100 references

Showing 100 of 118.