7.5

CVE-2021-23840: Integer overflow in CipherUpdate

Modified
AliasesALPINE-CVE-2021-23840UBUNTU-CVE-2021-23840DEBIAN-CVE-2021-23840
Published 16-02-2021Last modified 16-04-2026

Vulnerability summary

CVE-2021-23840 is a high (CVSS 7.5) Integer Overflow or Wraparound vulnerability in debian debian_linux. EPSS estimates a 50.73% chance of exploitation in the next 30 days, higher than 98.9% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 51% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
50.73%
0%100%
Critical · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 32 · Related 23

Timeline

  1. 16-02-2021
    PublishedVulnerability first disclosed.
  2. 16-04-2026
    Last modifiedVulnerability information updated.

Description

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

CVSS metrics

7 scores · 6 sources · 2 versions

EPSS trend

Probability

50.73%

Chance of exploitation in the next 30 days

Percentile

99%

Versus all other CVEs

30-day change

No change 0.00 pp

From 50.73% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Oracle9 products
Fujitsu6 products
Ubuntu4 products
  • edk2All versions (No fix recorded) | < 0~20191122.bd85bf54-2ubuntu3.3
  • nodejsAll versions (No fix recorded)
  • openssl< 1.0.1f-1ubuntu2.27+esm10 | < 1.0.2g-1ubuntu4.19 | < 1.0.2g-1ubuntu4.fips.4.19.3 | All versions (No fix recorded) | < 1.1.1-1ubuntu2.1~18.04.8 | < 1.1.1-1ubuntu2.fips.2.1~18.04.9.1 | < 1.1.1f-1ubuntu2.2 | < 1.1.1f-1ubuntu2.fips.7.2 | < 1.1.1f-1ubuntu2.fips.2.8
  • openssl1.0< 1.0.2n-1ubuntu5.6
Alpine3 products
  • openssl≥ 1.0.2, < 1.1.1j-r0
  • openssl1.1-compat< 1.1.1j-r0
  • openssl3< 1.1.1j-r0
Debian2 products
Tenable2 products
Crates.Io1 product
  • openssl-src< 111.14.0 | ≥ 0.0.0-0, < 111.14.0
Mcafee1 product
  • epolicy_orchestrator< 5.10.0 | 5.10.0 | 5.10.0:update_1 | 5.10.0:update_10 | 5.10.0:update_2 | 5.10.0:update_3 | 5.10.0:update_4 | 5.10.0:update_5 | 5.10.0:update_6 | 5.10.0:update_7 | 5.10.0:update_8 | 5.10.0:update_9
Nodejs1 product
  • node.jsEOL≥ 10.0.0, ≤ 10.12.0 | ≥ 10.13.0, < 10.24.0 | ≥ 12.0.0, ≤ 12.12.0 | ≥ 12.13.0, < 12.21.0 | ≥ 14.0.0, ≤ 14.14.0 | ≥ 15.0.0, < 15.10.0 | 14.15.0
Openssl1 product
  • opensslFixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i) | Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x) | ≥ 1.0.2, < 1.0.2y | ≥ 1.1.1, < 1.1.1j

10 vendors · 30 products

References

36 links
Show all 36 references