7.8

CVE-2021-41103: Insufficiently restricted permissions on plugin directories

Modified
AliasesUBUNTU-CVE-2021-41103USN-5100-1DEBIAN-CVE-2021-41103
Published 04-10-2021Last modified 04-08-2024

Vulnerability summary

CVE-2021-41103 is a high (CVSS 7.8) vulnerability in containerd. EPSS estimates a 0.52% chance of exploitation in the next 30 days, higher than 44.1% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.9, local access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
7.8/10
010
High · v3.1 (NVD)
EPSS score
0.52%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 11 · Related 12

Timeline

  1. 04-10-2021
    PublishedVulnerability first disclosed.
  2. 04-08-2024
    Last modifiedVulnerability information updated.

Description

containerd is an open source container runtime with an emphasis on simplicity, robustness and portability. A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability. Users unable to update should limit access to the host to trusted users. Update directory permission on container bundles directories.

CVSS metrics

11 scores · 8 sources · 3 versions

EPSS trend

Probability

0.52%

Chance of exploitation in the next 30 days

Percentile

44%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.52% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: local access, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Debian2 products
  • containerd< 1.4.5~ds1-2+deb11u1 | < 1.5.7~ds1-1
  • debian_linuxEOL11.0
Alpine1 product
  • containerd≥ 1.5.0, < 1.5.7-r0
Chainguard1 product
  • ctop< 0.7.7-r13
Containerd1 product
Fedoraproject1 product
Github.com/containerd1 product
  • containerd< 1.4.11 | ≥ 1.5.0, < 1.5.7
Linuxfoundation1 product
Opensuse1 product
  • containerd&distro=openSUSE Tumbleweed< 1.4.11-1.1
Ubuntu1 product
  • containerd< 1.5.2-0ubuntu1~18.04.3 | < 1.5.2-0ubuntu1~20.04.3 | < 1.2.6-0ubuntu1~16.04.6+esm2 | < 1.5.5-0ubuntu3
Wolfi1 product
  • ctop< 0.7.7-r13

10 vendors · 11 products

References

22 links
Show all 22 references