CVE-2022-1658: Jupiter Theme <= 6.10.1 - Authenticated Arbitrary Plugin Deletion
Vulnerability summary
CVE-2022-1658 is a medium (CVSS 6.5) Improper Access Control vulnerability in artbees jupiter. EPSS estimates a 0.73% chance of exploitation in the next 30 days, higher than 53.8% of scored vulnerabilities. 1 public exploit is recorded. Fixed in 6.10.2.
Timeline
- 13-06-2022PublishedVulnerability first disclosed.
- 31-01-2025Last modifiedVulnerability information updated.
Description
Vulnerable versions of the Jupiter Theme (<= 6.10.1) allow arbitrary plugin deletion by any authenticated user, including users with the subscriber role, via the abb_remove_plugin AJAX action registered in the framework/admin/control-panel/logic/plugin-management.php file. Using this functionality, any logged-in user can delete any installed plugin on the site.
CVSS metrics
4 scores · 3 sources · 2 versions- CVE.orgCNA5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:LDiffers
- NVDNIST5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:LDiffers
EPSS trend
Probability
0.73%
Chance of exploitation in the next 30 days
Percentile
54%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.73% on 27-09-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundExploit Reference (wordfence.com)
Maturity: unknown
Weaknesses
CWE · root causeAffected systems
Artbees1 product
- jupiter6.10.1 | ≤ 6.10.1
Wordpress1 product
- jupiter≤ 6.10.1 (fixed in 6.10.2)
2 vendors · 2 products