CVE-2022-1659: JupiterX Core <= 2.0.6 - Information Disclosure, Modification, and Denial of Service
Vulnerability summary
CVE-2022-1659 is a high (CVSS 7.5) Improper Access Control vulnerability in artbees jupiter x core. EPSS estimates a 0.85% chance of exploitation in the next 30 days, higher than 58% of scored vulnerabilities. 1 public exploit is recorded. Fixed in 2.0.7.
Timeline
- 13-06-2022PublishedVulnerability first disclosed.
- 31-01-2025Last modifiedVulnerability information updated.
Description
Vulnerable versions of the JupiterX Core (<= 2.0.6) plugin register an AJAX action jupiterx_conditional_manager which can be used to call any function in the includes/condition/class-condition-manager.php file by sending the desired function to call in the sub_action parameter. This can be used to view site configuration and logged-in users, modify post conditions, or perform a denial of service attack.
CVSS metrics
4 scores · 3 sources · 2 versions- NVDNIST7.3HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LDiffers
- wordfenceSource6.3MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LDiffers
EPSS trend
Probability
0.85%
Chance of exploitation in the next 30 days
Percentile
58%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.85% on 27-09-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundExploit Reference (wordfence.com)
Maturity: unknown
Weaknesses
CWE · root causeAffected systems
Artbees2 products
- jupiter x core2.0.6
- jupiterx≤ 2.0.6
Wordpress1 product
- jupiterx-core≤ 2.0.6 (fixed in 2.0.7)
2 vendors · 3 products