CVE-2022-2068: The c_rehash script allows command injection
Vulnerability summary
CVE-2022-2068 is a high (CVSS 10.0) vulnerability in broadcom sannav. EPSS estimates a 96.39% chance of exploitation in the next 30 days, higher than 99.8% of scored vulnerabilities.
Severe, CVSS 9.8 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 96% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 21 · Related 14Timeline
- 21-06-2022PublishedVulnerability first disclosed.
- 14-10-2026Last modifiedVulnerability information updated.
Description
In addition to the c_rehash shell command injection identified in CVE-2022-1292, further circumstances where the c_rehash script does not properly sanitise shell metacharacters to prevent command injection were found by code review. When the CVE-2022-1292 was fixed it was not discovered that there are other places in the script where the file names of certificates being hashed were possibly passed to a command executed through the shell. This script is distributed by some operating systems in a manner where it is automatically executed. On such operating systems, an attacker could execute arbitrary commands with the privileges of the script. Use of the c_rehash script is considered obsolete and should be replaced by the OpenSSL rehash command line tool. Fixed in OpenSSL 3.0.4 (Affected 3.0.0,3.0.1,3.0.2,3.0.3). Fixed in OpenSSL 1.1.1p (Affected 1.1.1-1.1.1o). Fixed in OpenSSL 1.0.2zf (Affected 1.0.2-1.0.2ze).
CVSS metrics
8 scores · 7 sources · 2 versions- OSV · AlpineEcosystem advisory · calculated7.3HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:HDiffers
- OSV · UbuntuEcosystem advisory · calculated7.3HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:HDiffers
- OSV · DebianEcosystem advisory · calculated7.3HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:HDiffers
- OSV · WolfiEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · ChainguardEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVDNIST7.3HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:HDiffers
EPSS trend
Probability
96.39%
Chance of exploitation in the next 30 days
Percentile
100%
Versus all other CVEs
30-day change
Increase +0.99 pp
From 95.40% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Netapp23 products
Suse20 products
- openssl-1_0_0&distro=SUSE Linux Enterprise Server 12 SP4-LTSS< 1.0.2p-3.56.1
- openssl-1_0_0&distro=SUSE Linux Enterprise Server 12 SP5< 1.0.2p-3.56.1
- openssl-1_0_0&distro=SUSE Linux Enterprise Server for SAP Applications 12 SP4< 1.0.2p-3.56.1
- openssl-1_0_0&distro=SUSE Linux Enterprise Server for SAP Applications 12 SP5< 1.0.2p-3.56.1
- openssl-1_0_0&distro=SUSE Linux Enterprise Software Development Kit 12 SP5< 1.0.2p-3.56.1
Ubuntu4 products
- edk2All versions (No fix recorded)
- nodejs< 12.22.9~dfsg-1ubuntu3.1
- openssl< 1.0.1f-1ubuntu2.27+esm10 | < 1.0.2g-1ubuntu4.fips.4.20.3 | All versions (No fix recorded) | < 1.1.1-1ubuntu2.fips.2.1~18.04.20 | < 1.1.1f-1ubuntu2.fips.16 | < 1.1.1-1ubuntu2.1~18.04.19 | < 1.1.1f-1ubuntu2.15 | < 3.0.2-0ubuntu1.5 | < 1.0.2g-1ubuntu4.20+esm5
- openssl1.0< 1.0.2n-1ubuntu5.10
Alpine2 products
- openssl≥ 1.0.2 (No fix recorded)
- openssl3All versions (No fix recorded)
Chainguard2 products
- eco-dotnet-libssl-1.0All versions (No fix recorded)
- ruby-3.1All versions (No fix recorded)
Debian2 products
- openssl< 1.1.1n-0+deb10u3 | < 1.1.1n-0+deb11u3 | < 3.0.4-1
- debian_linuxEOL10.0 | 11.0
Broadcom1 product
- sannavna
Fedoraproject1 product
- fedoraEOL35 | 36
Mageia1 product
- openssl< 1.1.1p-1.mga8
Openssl1 product
- opensslFixed in OpenSSL 3.0.4 (Affected 3.0.0,3.0.1,3.0.2,3.0.3) | Fixed in OpenSSL 1.1.1p (Affected 1.1.1-1.1.1o) | Fixed in OpenSSL 1.0.2zf (Affected 1.0.2-1.0.2ze) | ≥ 1.0.2, < 1.0.2zf | ≥ 1.1.1, < 1.1.1p | ≥ 3.0.0, < 3.0.4
Opensuse1 product
- openssl-1_1&distro=openSUSE Tumbleweed< 1.1.1p-1.1
Siemens1 product
- sinec_ins< 1.0 | 1.0 | 1.0:sp1 | 1.0:sp2
Wolfi1 product
- ruby-3.1All versions (No fix recorded)
13 vendors · 60 products