CVE-2022-23485: Invite code reuse via cookie manipulation in sentry
Vulnerability summary
CVE-2022-23485 is a medium (CVSS 6.4) Improper Privilege Management vulnerability in getsentry sentry. EPSS estimates a 0.45% chance of exploitation in the next 30 days, higher than 39.2% of scored vulnerabilities.
Not severe (CVSS 6.4, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 10-12-2022PublishedVulnerability first disclosed.
- 23-04-2025Last modifiedVulnerability information updated.
Description
Sentry is an error tracking and performance monitoring platform. In versions of the sentry python library prior to 22.11.0 an attacker with a known valid invite link could manipulate a cookie to allow the same invite link to be reused on multiple accounts when joining an organization. As a result an attacker with a valid invite link can create multiple users and join an organization they may not have been originally invited to. This issue was patched in version 22.11.0. Sentry SaaS customers do not need to take action. Self-hosted Sentry installs on systems which can not upgrade can disable the invite functionality until they are ready to deploy the patched version by editing their `sentry.conf.py` file (usually located at `~/.sentry/`).
CVSS metrics
4 scores · 4 sources · 1 version- OSV · PypiEcosystem advisory · calculated6.4MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L
- OSV · UbuntuEcosystem advisory · calculated3.7LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:NDiffers
- NVDNIST3.7LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:NDiffers
EPSS trend
Probability
0.45%
Chance of exploitation in the next 30 days
Percentile
39%
Versus all other CVEs
30-day change
Increase +0.02 pp
From 0.43% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-269Improper Privilege ManagementThe product does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.
- CWE-284Improper Access ControlThe product does not restrict or incorrectly restricts access to a resource from an unauthorized actor.
Affected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Getsentry1 product
- sentry≥ 20.6.0, < 22.11.0
PyPI1 product
- sentry≥ 20.6.0, < 22.11.0
Sentry1 product
- sentry≥ 20.6.0, ≤ 22.10.0
Ubuntu1 product
- sentry-pythonAll versions (No fix recorded)
4 vendors · 4 products
References
7 links- github.com/getsentry/sentry/security/advisories/GHSA-jv85-mqxj-3f9jX Refsource CONFIRMWEBAdvisoryREPORTMitigationThird Party Advisory
- github.com/getsentry/sentryPACKAGE