CVE-2022-23499: Cross-Site Scripting Protection bypass in HTML Sanitizer
Vulnerability summary
CVE-2022-23499 is a medium (CVSS 6.1) vulnerability in typo3 html_sanitizer. EPSS estimates a 0.47% chance of exploitation in the next 30 days, higher than 40.5% of scored vulnerabilities.
Not severe (CVSS 6.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 13-12-2022PublishedVulnerability first disclosed.
- 23-04-2025Last modifiedVulnerability information updated.
Description
HTML sanitizer is written in PHP, aiming to provide XSS-safe markup based on explicitly allowed tags, attributes and values. In versions prior to 1.5.0 or 2.1.1, malicious markup used in a sequence with special HTML CDATA sections cannot be filtered and sanitized due to a parsing issue in the upstream package masterminds/html5. This allows bypassing the cross-site scripting mechanism of typo3/html-sanitizer. The upstream package masterminds/html5 provides HTML raw text elements (`script`, `style`, `noframes`, `noembed` and `iframe`) as DOMText nodes, which were not processed and sanitized further. None of the mentioned elements were defined in the default builder configuration, that's why only custom behaviors, using one of those tag names, were vulnerable to cross-site scripting. This issue has been fixed in versions 1.5.0 and 2.1.1.
CVSS metrics
2 scores · 2 sources · 1 version- NVDNIST6.1MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS trend
Probability
0.47%
Chance of exploitation in the next 30 days
Percentile
41%
Versus all other CVEs
30-day change
Increase +0.02 pp
From 0.45% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Typo32 products
- html_sanitizer≥ 1.0.0, ≤ 1.0.7 | ≥ 2.0.0, < 2.1.1
- html-sanitizer≥ 1.0.0, < 1.5.0 | ≥ 2.0.0, < 2.1.1
1 vendor · 2 products
References
1 links- github.com/TYPO3/html-sanitizer/security/advisories/GHSA-hvwx-qh2h-xcfjX Refsource CONFIRMThird Party Advisory