CVE-2022-23552: Grafana stored XSS in FileUploader component
Vulnerability summary
CVE-2022-23552 is a high (CVSS 7.3) vulnerability in grafana. EPSS estimates a 0.78% chance of exploitation in the next 30 days, higher than 55.9% of scored vulnerabilities.
Not severe (CVSS 7.3, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 7 · Related 6Timeline
- 27-01-2023PublishedVulnerability first disclosed.
- 28-01-2026Last modifiedVulnerability information updated.
Description
Grafana is an open-source platform for monitoring and observability. Starting with the 8.1 branch and prior to versions 8.5.16, 9.2.10, and 9.3.4, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. The stored XSS vulnerability was possible because SVG files weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance. An attacker needs to have the Editor role in order to change a panel to include either an external URL to a SVG-file containing JavaScript, or use the `data:` scheme to load an inline SVG-file containing JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.16, 9.2.10, or 9.3.4 to receive a fix.
CVSS metrics
2 scores · 2 sources · 1 version- NVDNIST5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NDiffers
EPSS trend
Probability
0.78%
Chance of exploitation in the next 30 days
Percentile
56%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.78% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.
Grafana1 product
- grafana≥ 9.0, < 9.2.10 | ≥ 9.3, < 9.3.4 | ≥ 8.1, < 8.5.16 | ≥ 8.1.0, < 8.5.16 | ≥ 9.0.0, < 9.2.10 | ≥ 9.3.0, < 9.3.4
1 vendor · 1 product
References
6 links- github.com/grafana/grafana/security/advisories/GHSA-8xmm-x63g-f6xvX Refsource CONFIRMThird Party Advisory
- github.com/grafana/grafana/commit/1c8a50b36973bd59a1cc5f34c30de8a9a6a431f0X Refsource MISCPatchThird Party Advisory
- github.com/grafana/grafana/commit/8b574e22b53aa4c5a35032a58844fd4aaaa12f5fX Refsource MISCPatchThird Party Advisory
- github.com/grafana/grafana/commit/c022534e3848a5d45c0b3face23b43aa44e4400aX Refsource MISCPatchThird Party Advisory