CVE-2022-23634: Information Exposure when using Puma with Rails
Vulnerability summary
CVE-2022-23634 is a high (CVSS 8.0) vulnerability in debian debian_linux. EPSS estimates a 2.11% chance of exploitation in the next 30 days, higher than 81.7% of scored vulnerabilities.
Not severe (CVSS 8, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 11 · Related 8Timeline
- 11-02-2022PublishedVulnerability first disclosed.
- 23-04-2025Last modifiedVulnerability information updated.
Description
Puma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, depended on the response body being closed in order for its `CurrentAttributes` implementation to work correctly. The combination of these two behaviors (Puma not closing the body + Rails' Executor implementation) causes information leakage. This problem is fixed in Puma versions 5.6.2 and 4.3.11. This problem is fixed in Rails versions 7.02.2, 6.1.4.6, 6.0.4.6, and 5.2.6.2. Upgrading to a patched Rails _or_ Puma version fixes the vulnerability.
CVSS metrics
6 scores · 5 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NDiffers
- OSV · DebianEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NDiffers
- OSV · RubygemsEcosystem advisory · calculated8.0HighCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- NVDNIST5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NDiffers
EPSS trend
Probability
2.11%
Chance of exploitation in the next 30 days
Percentile
82%
Versus all other CVEs
30-day change
No change 0.00 pp
From 2.11% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-200Exposure of Sensitive Information to an Unauthorized ActorThe product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
- CWE-404Improper Resource Shutdown or ReleaseThe product does not release or incorrectly releases a resource before it is made available for re-use.
Affected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Debian2 products
- puma< 5.6.4-1
- debian_linuxEOL9.0 | 10.0 | 11.0
Fedoraproject1 product
- fedoraEOL35 | 36 | 37
Puma1 product
- puma< 4.3.11 | ≥ 5.0.0, < 5.6.2
RubyGems1 product
- puma≥ 5.0.0, < 5.6.2 | < 4.3.11
Rubyonrails1 product
- rails≥ 5.0.0, < 5.2.6.2 | ≥ 6.0.0, < 6.0.4.6 | ≥ 6.1.0, < 6.1.4.6 | ≥ 7.0.0, < 7.0.2.2
Ubuntu1 product
- puma< 3.12.4-1ubuntu2+esm1 | < 5.5.2-2ubuntu2+esm1
6 vendors · 7 products
References
22 links- github.com/puma/puma/security/advisories/GHSA-rmj8-8hhh-gv5hX Refsource CONFIRMREPORTWEBPatchThird Party Advisory
- github.com/puma/puma/commit/b70f451fe8abc0cff192c065d549778452e155bbX Refsource MISCREPORTWEBPatchThird Party Advisory
- github.com/advisories/GHSA-wh98-p28r-vrc9X Refsource MISCREPORTAdvisoryMitigationNot ApplicableThird Party Advisory
- lists.debian.org/debian-lts-announce/2022/05/msg00034.htmlMailing ListX Refsource MLISTWEBThird Party Advisory
- lists.debian.org/debian-lts-announce/2022/08/msg00015.htmlMailing ListX Refsource MLISTWEBThird Party Advisory
Show all 22 references
- github.com/puma/pumaPACKAGE