7.5

CVE-2022-24761: HTTP Request Smuggling in waitress

Modified
AliasesMGASA-2022-0182SUSE-SU-2022:3583-1SUSE-SU-2022:3635-1
Published 17-03-2022Last modified 23-04-2025

Vulnerability summary

CVE-2022-24761 is a high (CVSS 7.5) vulnerability in agendaless waitress. EPSS estimates a 1.78% chance of exploitation in the next 30 days, higher than 78.2% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 2% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
1.78%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 2 · Related 1

Timeline

  1. 17-03-2022
    PublishedVulnerability first disclosed.
  2. 23-04-2025
    Last modifiedVulnerability information updated.

Description

Waitress is a Web Server Gateway Interface server for Python 2 and 3. When using Waitress versions 2.1.0 and prior behind a proxy that does not properly validate the incoming HTTP request matches the RFC7230 standard, Waitress and the frontend proxy may disagree on where one request starts and where it ends. This would allow requests to be smuggled via the front-end proxy to waitress and later behavior. There are two classes of vulnerability that may lead to request smuggling that are addressed by this advisory: The use of Python's `int()` to parse strings into integers, leading to `+10` to be parsed as `10`, or `0x01` to be parsed as `1`, where as the standard specifies that the string should contain only digits or hex digits; and Waitress does not support chunk extensions, however it was discarding them without validating that they did not contain illegal characters. This vulnerability has been patched in Waitress 2.1.1. A workaround is available. When deploying a proxy in front of waitress, turning on any and all functionality to make sure that the request matches the RFC7230 standard. Certain proxy servers may not have this functionality though and users are encouraged to upgrade to the latest version of waitress instead.

CVSS metrics

8 scores · 6 sources · 3 versions

EPSS trend

Probability

1.78%

Chance of exploitation in the next 30 days

Percentile

78%

Versus all other CVEs

30-day change

No change 0.00 pp

From 1.78% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Suse28 products
  • python-waitress&distro=HPE Helion OpenStack 8< 1.4.3-3.6.1
  • python-waitress&distro=SUSE Enterprise Storage 6< 1.4.3-150000.3.6.1
  • python-waitress&distro=SUSE Enterprise Storage 7< 1.4.3-150000.3.6.1
  • python-waitress&distro=SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS< 1.4.3-150000.3.6.1
  • python-waitress&distro=SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS< 1.4.3-150000.3.6.1
Redhat3 products
  • python-waitress< 0:2.0.0-1.el8ost | < 0:1.4.4-2.el7ost
  • python2-waitress< 0:1.4.4-2.el7ost
  • python3-waitress< 0:2.0.0-1.el8ost
Debian2 products
  • waitress< 1.2.0~b2-2+deb10u1 | < 1.4.4-1.1+deb11u1 | < 2.1.1-1
  • debian_linuxEOL9.0
Opensuse2 products
  • python-waitress&distro=openSUSE Leap 15.3< 1.4.3-150000.3.6.1
  • python-waitress&distro=openSUSE Leap 15.4< 1.4.3-150000.3.6.1
Agendaless1 product
Mageia1 product
  • python-waitress< 2.1.1-1.mga8
Pylons1 product
PyPI1 product
  • waitress< 9e0b8c801e4d505c2ffc91b891af4ba48af715e0 | < 2.1.1
Ubuntu1 product
  • waitress< 1.4.4-1.1ubuntu1 | < 1.4.1-1ubuntu0.1

9 vendors · 40 products

References

28 links
Show all 28 references