CVE-2022-24817: Improper kubeconfig validation allows arbitrary code execution
Vulnerability summary
CVE-2022-24817 is a critical (CVSS 9.9) Improper Control of Generation of Code vulnerability in fluxcd flux2. EPSS estimates a 1.12% chance of exploitation in the next 30 days, higher than 66.1% of scored vulnerabilities.
Severe, CVSS 9.9 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Timeline
- 06-05-2022PublishedVulnerability first disclosed.
- 23-04-2025Last modifiedVulnerability information updated.
Description
Flux2 is an open and extensible continuous delivery solution for Kubernetes. Flux2 versions between 0.1.0 and 0.29.0, helm-controller 0.1.0 to v0.19.0, and kustomize-controller 0.1.0 to v0.23.0 are vulnerable to Code Injection via malicious Kubeconfig. In multi-tenancy deployments this can also lead to privilege escalation if the controller's service account has elevated permissions. Workarounds include disabling functionality via Validating Admission webhooks by restricting users from setting the `spec.kubeConfig` field in Flux `Kustomization` and `HelmRelease` objects. Additional mitigations include applying restrictive AppArmor and SELinux profiles on the controller’s pod to limit what binaries can be executed. This vulnerability is fixed in kustomize-controller v0.23.0 and helm-controller v0.19.0, both included in flux2 v0.29.0
CVSS metrics
4 scores · 3 sources · 2 versions- OSV · GoEcosystem advisory · calculated9.9CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- NVDNIST9.9CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS trend
Probability
1.12%
Chance of exploitation in the next 30 days
Percentile
66%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.12% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Fluxcd3 products
- flux2flux2 < v0.29.0 >= v0.1.0 | helm-controller < v0.23.0 >= v0.1.0 | kustomize-controller < v0.19.0 >= v0.2.0 | ≥ 0.1.0, < 0.29.0
- helm-controller≥ 0.2.0, < 0.19.0
- kustomize-controller≥ 0.1.0, < 0.23.0
Github.com/fluxcd3 products
- flux2≥ 0.1.0, < 0.29.0
- helm-controller≥ 0.2.0, < 0.19.0
- kustomize-controller≥ 0.1.0, < 0.23.0
2 vendors · 6 products
References
3 links- github.com/fluxcd/flux2/security/advisories/GHSA-vvmq-fwmg-2gjcX Refsource CONFIRMWEBPatchThird Party Advisory
- github.com/fluxcd/flux2PACKAGE