5.5

CVE-2022-31030: containerd CRI plugin: Host memory exhaustion through ExecSync

Modified
AliasesMGASA-2022-0227UBUNTU-CVE-2022-31030DEBIAN-CVE-2022-31030
Published 06-06-2022Last modified 03-08-2024

Vulnerability summary

CVE-2022-31030 is a medium (CVSS 5.5) Uncontrolled Resource Consumption vulnerability in containerd. EPSS estimates a 0.39% chance of exploitation in the next 30 days, higher than 32.8% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.5, local access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
5.5/10
010
Medium · v3.1 (CVE.org)
EPSS score
0.39%
0%100%
Low · +0.01 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 5 · Related 6

Timeline

  1. 06-06-2022
    PublishedVulnerability first disclosed.
  2. 03-08-2024
    Last modifiedVulnerability information updated.

Description

containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.

CVSS metrics

9 scores · 8 sources · 2 versions

EPSS trend

Probability

0.39%

Chance of exploitation in the next 30 days

Percentile

33%

Versus all other CVEs

30-day change

Increase +0.01 pp

From 0.38% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: local access, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.

Debian2 products
Alpine1 product
  • containerd≥ 1.6.0, < 1.6.6-r0
Chainguard1 product
  • ctop< 0.7.7-r13
Containerd1 product
Fedoraproject1 product
Github.com/containerd1 product
  • containerd< 1.5.13 | ≥ 1.6.0, < 1.6.6
Linuxfoundation1 product
Mageia1 product
  • docker-containerd< 1.5.13-1.mga8
Opensuse1 product
  • containerd&distro=openSUSE Tumbleweed< 1.6.6-1.1
Ubuntu1 product
  • containerd< 1.2.6-0ubuntu1~16.04.6+esm2 | < 1.5.9-0ubuntu1~18.04.2 | < 1.5.9-0ubuntu1~20.04.6 | < 1.5.9-0ubuntu3.1
Wolfi1 product
  • ctop< 0.7.7-r13

11 vendors · 12 products

References

23 links
Show all 23 references