6.1

CVE-2022-31160: jQuery UI contains potential XSS vulnerability when refreshing a checkboxradio with an HTML-like initial text label

Modified
AliasesUBUNTU-CVE-2022-31160DEBIAN-CVE-2022-31160GHSA-h6gj-6jjq-h8g9
Published 20-07-2022Last modified 22-04-2025

Vulnerability summary

CVE-2022-31160 is a medium (CVSS 6.1) vulnerability in debian debian_linux. EPSS estimates a 2.69% chance of exploitation in the next 30 days, higher than 85.8% of scored vulnerabilities. 1 public exploit is recorded.

Priority
Routine

Not severe (CVSS 6.1, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
6.1/10
010
Medium · v3.1 (CVE.org)
EPSS score
2.69%
0%100%
Low · +0.05 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits1github

Advisory lineage

Upstream 0 · Downstream 3 · Related 2

Timeline

  1. 20-07-2022
    PublishedVulnerability first disclosed.
  2. 22-04-2025
    Last modifiedVulnerability information updated.

Description

jQuery UI is a curated set of user interface interactions, effects, widgets, and themes built on top of jQuery. Versions prior to 1.13.2 are potentially vulnerable to cross-site scripting. Initializing a checkboxradio widget on an input enclosed within a label makes that parent label contents considered as the input label. Calling `.checkboxradio( "refresh" )` on such a widget and the initial HTML contained encoded HTML entities will make them erroneously get decoded. This can lead to potentially executing JavaScript code. The bug has been patched in jQuery UI 1.13.2. To remediate the issue, someone who can change the initial HTML can wrap all the non-input contents of the `label` in a `span`.

CVSS metrics

8 scores · 8 sources · 1 version

EPSS trend

Probability

2.69%

Chance of exploitation in the next 30 days

Percentile

86%

Versus all other CVEs

30-day change

Increase +0.05 pp

From 2.64% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

1 found
  • githubUnverified

    Jquery Ui

    Maturity: poc

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.

Netapp6 products
Debian2 products
Drupal1 product
Fedoraproject1 product
Jquery1 product
Jqueryui1 product
Npm1 product
  • jquery-ui< 1.13.2
NuGet1 product
  • jQuery.UI.Combined< 1.13.2
Org.webjars.npm1 product
  • jquery-ui< 1.13.2
RubyGems1 product
  • jquery-ui-rails< 8.0.0
Ubuntu1 product
  • jqueryui< 1.12.1+dfsg-5ubuntu0.18.04.1~esm2 | < 1.12.1+dfsg-5ubuntu0.20.04.1 | < 1.12.1+dfsg-5ubuntu0.20.04.1~esm3 | < 1.13.1+dfsg-1ubuntu0.1~esm1

11 vendors · 17 products

References

24 links
Show all 24 references