8

CVE-2022-3534: Linux Kernel libbpf btf_dump.c btf_dump_name_dups use after free

Modified
AliasesUBUNTU-CVE-2022-3534DEBIAN-CVE-2022-3534CGA-2275-5874-cvrf
Published 17-10-2022Last modified 14-10-2026

Vulnerability summary

CVE-2022-3534 is a high (CVSS 8.0) vulnerability in debian debian_linux. EPSS estimates a 0.96% chance of exploitation in the next 30 days, higher than 61.6% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.1, adjacent network); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
8.0/10
010
High · v3.1 (NVD)
EPSS score
0.96%
0%100%
Low · +0.05 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 7 · Related 5

Timeline

  1. 17-10-2022
    PublishedVulnerability first disclosed.
  2. 14-10-2026
    Last modifiedVulnerability information updated.

Description

A vulnerability has been found in Linux Kernel up to 5.10.162/5.15.85/6.0.15/6.1.1. The impacted element is the function btf_dump_name_dups of the file tools/lib/bpf/btf_dump.c of the component libbpf. The manipulation leads to use after free. Upgrading to version 5.10.163, 5.15.86, 6.0.16, 6.1.2 and 6.2 is sufficient to resolve this issue. The identifier of the patch is c61650b869e0b6fb0c0a28ed42d928eea969afc8/fbe08093fb2334549859829ef81d42570812597d/8c64a8e76eb85d422af5ec60ccbf26e3ead8c333/a733bf10198eb5bb927890940de8ab457491ed3b/93c660ca40b5d2f7c1b1626e955a8e9fa30e0749. You should upgrade the affected component.

CVSS metrics

11 scores · 5 sources · 4 versions

EPSS trend

Probability

0.96%

Chance of exploitation in the next 30 days

Percentile

62%

Versus all other CVEs

30-day change

Increase +0.05 pp

From 0.91% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: adjacent network, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard52 products
  • hyperv-daemons-6.18All versions (No fix recorded)
  • hyperv-daemons-genericAll versions (No fix recorded)
  • linux-aws-6.12< 6.12.65-r0 | All versions (No fix recorded)
  • linux-aws-6.12-boot-installedAll versions (No fix recorded)
  • linux-aws-6.12-fips-boot-installedAll versions (No fix recorded)
Debian2 products
Linux2 products
  • kernel5.10.162 | 5.15.0 | 5.15.1 | 5.15.2 | 5.15.3 | 5.15.4 | 5.15.5 | 5.15.6 | 5.15.7 | 5.15.8 | 5.15.9 | 5.15.10 | 5.15.11 | 5.15.12 | 5.15.13 | 5.15.14 | 5.15.15 | 5.15.16 | 5.15.17 | 5.15.18 | 5.15.19 | 5.15.20 | 5.15.21 | 5.15.22 | 5.15.23 | 5.15.24 | 5.15.25 | 5.15.26 | 5.15.27 | 5.15.28 | 5.15.29 | 5.15.30 | 5.15.31 | 5.15.32 | 5.15.33 | 5.15.34 | 5.15.35 | 5.15.36 | 5.15.37 | 5.15.38 | 5.15.39 | 5.15.40 | 5.15.41 | 5.15.42 | 5.15.43 | 5.15.44 | 5.15.45 | 5.15.46 | 5.15.47 | 5.15.48 | 5.15.49 | 5.15.50 | 5.15.51 | 5.15.52 | 5.15.53 | 5.15.54 | 5.15.55 | 5.15.56 | 5.15.57 | 5.15.58 | 5.15.59 | 5.15.60 | 5.15.61 | 5.15.62 | 5.15.63 | 5.15.64 | 5.15.65 | 5.15.66 | 5.15.67 | 5.15.68 | 5.15.69 | 5.15.70 | 5.15.71 | 5.15.72 | 5.15.73 | 5.15.74 | 5.15.75 | 5.15.76 | 5.15.77 | 5.15.78 | 5.15.79 | 5.15.80 | 5.15.81 | 5.15.82 | 5.15.83 | 5.15.84 | 5.15.85 | 6.0.0 | 6.0.1 | 6.0.2 | 6.0.3 | 6.0.4 | 6.0.5 | 6.0.6 | 6.0.7 | 6.0.8 | 6.0.9 | 6.0.10 | 6.0.11 | 6.0.12 | 6.0.13 | 6.0.14 | 6.0.15 | 6.1.0 | 6.1.1
  • linux_kernel≥ 5.10, < 5.10.163 | ≥ 5.11, < 5.15.86 | ≥ 5.16, < 6.0.16 | ≥ 6.1, < 6.1.2
Ubuntu2 products
  • dwarves-dfsgAll versions (No fix recorded) | < 1.21-0ubuntu1~18.04.1+esm1 | < 1.21-0ubuntu1~20.04.1
  • libbpf< 0.5.0-1~ubuntu20.04.1+esm1 | < 0.5.0-1ubuntu22.04.1

4 vendors · 58 products

References

14 links
Show all 14 references