7.5

CVE-2022-37599: webpack.js loader-utils

Modified
AliasesUBUNTU-CVE-2022-37599DEBIAN-CVE-2022-37599GHSA-hhq3-ff78-jv3g
Published 11-10-2022Last modified 04-11-2025

Vulnerability summary

CVE-2022-37599 is a high (CVSS 7.5) vulnerability in webpack.js loader-utils. EPSS estimates a 2.76% chance of exploitation in the next 30 days, higher than 86.2% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (NVD); no exploitation reported by the 5 checked sources; EPSS 3% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (NVD)
EPSS score
2.76%
0%100%
Low · +0.51 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 1

Timeline

  1. 11-10-2022
    PublishedVulnerability first disclosed.
  2. 04-11-2025
    Last modifiedVulnerability information updated.

Description

A Regular expression denial of service (ReDoS) flaw was found in Function interpolateName in interpolateName.js in webpack loader-utils 2.0.0 via the resourcePath variable in interpolateName.js.

CVSS metrics

5 scores · 5 sources · 1 version

EPSS trend

Probability

2.76%

Chance of exploitation in the next 30 days

Percentile

86%

Versus all other CVEs

30-day change

Increase +0.51 pp

From 2.25% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Wordpress4 products
  • elasticpress≤ 4.3.1 (fixed in 4.4.0)
  • insert-special-characters≤ 1.0.5 (fixed in 1.0.6)
  • restricted-site-access≤ 7.3.4 (fixed in 7.3.5)
  • simple-page-ordering≤ 2.4.3 (fixed in 2.4.4)
Debian1 product
  • node-loader-utils< 2.0.4-1
Npm1 product
  • loader-utils≥ 1.0.0, < 1.4.2 | ≥ 2.0.0, < 2.0.4 | ≥ 3.0.0, < 3.2.1
Ubuntu1 product
  • node-loader-utilsAll versions (No fix recorded)
Webpack.js1 product
  • loader-utils≥ 1.0.0, < 1.4.2 | ≥ 2.0.0, < 2.0.4 | ≥ 3.0.0, < 3.2.1

5 vendors · 8 products

References

19 links
Show all 19 references