9.8

CVE-2022-41853: Remote code execution in HyperSQL DataBase

Modified
AliasesSUSE-SU-2022:3864-1RHSA-2022:8559RHSA-2022:8560
Published 06-10-2022Last modified 21-04-2025

Vulnerability summary

CVE-2022-41853 is a critical (CVSS 9.8) vulnerability in debian debian_linux. EPSS estimates a 5.15% chance of exploitation in the next 30 days, higher than 92.4% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 8, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
9.8/10
010
Critical · v3.1 (NVD)
EPSS score
5.15%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 5

Timeline

  1. 06-10-2022
    PublishedVulnerability first disclosed.
  2. 21-04-2025
    Last modifiedVulnerability information updated.

Description

Those using java.sql.Statement or java.sql.PreparedStatement in hsqldb (HyperSQL DataBase) to process untrusted input may be vulnerable to a remote code execution attack. By default it is allowed to call any static method of any Java class in the classpath resulting in code execution. The issue can be prevented by updating to 2.7.1 or by setting the system property "hsqldb.method_class_names" to classes which are allowed to be called. For example, System.setProperty("hsqldb.method_class_names", "abc") or Java argument -Dhsqldb.method_class_names="abc" can be used. From version 2.7.1 all classes by default are not accessible except those in java.lang.Math and need to be manually enabled.

CVSS metrics

6 scores · 6 sources · 1 version

EPSS trend

Probability

5.15%

Chance of exploitation in the next 30 days

Percentile

92%

Versus all other CVEs

30-day change

No change 0.00 pp

From 5.15% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.

Redhat4 products
  • hsqldb< 1:1.8.0.10-13.el6_10 | < 1:1.8.1.3-15.el7_9
  • hsqldb-demo< 1:1.8.0.10-13.el6_10 | < 1:1.8.1.3-15.el7_9
  • hsqldb-javadoc< 1:1.8.0.10-13.el6_10 | < 1:1.8.1.3-15.el7_9
  • hsqldb-manual< 1:1.8.0.10-13.el6_10 | < 1:1.8.1.3-15.el7_9
Debian2 products
  • hsqldb< 2.5.1-1+deb11u1 | < 2.4.1-2+deb10u1 | < 2.7.1-1
  • debian_linuxEOL10.0 | 11.0
Opensuse2 products
  • hsqldb&distro=openSUSE Leap 15.3< 2.3.3-150000.7.3.1
  • hsqldb&distro=openSUSE Leap 15.4< 2.3.3-150000.7.3.1
Hsqldb1 product
Hypersql database1 product
  • hsqldb≥ unspecified, < 2.7.1
Org.hsqldb1 product
  • hsqldb< 2.7.1
Suse1 product
  • hsqldb&distro=SUSE Linux Enterprise Software Development Kit 12 SP5< 2.2.9-5.3.1
Ubuntu1 product
  • hsqldbAll versions (No fix recorded)

8 vendors · 13 products

References

21 links
Show all 21 references