CVE-2022-41881: debian debian_linux Uncontrolled Recursion
Vulnerability summary
CVE-2022-41881 is a high (CVSS 7.5) Uncontrolled Recursion vulnerability in debian debian_linux. EPSS estimates a 1.58% chance of exploitation in the next 30 days, higher than 75.5% of scored vulnerabilities. 1 public exploit is recorded.
Not severe (CVSS 5.3, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 14 · Related 6Timeline
- 12-12-2022PublishedVulnerability first disclosed.
- 22-04-2025Last modifiedVulnerability information updated.
Description
Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.
CVSS metrics
5 scores · 5 sources · 1 version- CVE.orgCNA5.3MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LDiffers
- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · MavenEcosystem advisory · calculated5.3MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LDiffers
EPSS trend
Probability
1.58%
Chance of exploitation in the next 30 days
Percentile
76%
Versus all other CVEs
30-day change
Increase +0.06 pp
From 1.52% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundNetty
Maturity: poc
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Debian2 products
- netty< 1:4.1.48-6
- debian_linuxEOL10.0 | 11.0
Ubuntu2 products
- nettyAll versions (No fix recorded) | < 1:4.0.34-1ubuntu0.1~esm1 | < 1:4.1.7-4ubuntu0.1+esm2 | < 1:4.1.45-1ubuntu0.1~esm1 | < 1:4.1.48-4+deb11u1build0.22.04.1
- netty-3.9All versions (No fix recorded)
Io.netty1 product
- netty-codec-haproxy< 4.1.86.Final
Netty1 product
- netty< 4.1.86.Final | < 4.1.86
4 vendors · 6 products
References
11 links- security.netapp.com/advisory/ntap-20230113-0004/Third Party Advisory
- github.com/netty/nettyPACKAGE