6.5

CVE-2022-41915: debian debian_linux

Modified
AliasesUBUNTU-CVE-2022-41915DEBIAN-CVE-2022-41915GHSA-hh82-3pmq-7frp
Published 13-12-2022Last modified 22-04-2025

Vulnerability summary

CVE-2022-41915 is a medium (CVSS 6.5) vulnerability in debian debian_linux. EPSS estimates a 0.95% chance of exploitation in the next 30 days, higher than 61.3% of scored vulnerabilities. 1 public exploit is recorded.

Priority
Routine

Not severe (CVSS 6.5, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
6.5/10
010
Medium · v3.1 (CVE.org)
EPSS score
0.95%
0%100%
Low · +0.03 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits1github

Advisory lineage

Upstream 0 · Downstream 6 · Related 5

Timeline

  1. 13-12-2022
    PublishedVulnerability first disclosed.
  2. 22-04-2025
    Last modifiedVulnerability information updated.

Description

Netty project is an event-driven asynchronous network application framework. Starting in version 4.1.83.Final and prior to 4.1.86.Final, when calling `DefaultHttpHeadesr.set` with an _iterator_ of values, header value validation was not performed, allowing malicious header values in the iterator to perform HTTP Response Splitting. This issue has been patched in version 4.1.86.Final. Integrators can work around the issue by changing the `DefaultHttpHeaders.set(CharSequence, Iterator<?>)` call, into a `remove()` call, and call `add()` in a loop over the iterator of values.

CVSS metrics

5 scores · 5 sources · 1 version

EPSS trend

Probability

0.95%

Chance of exploitation in the next 30 days

Percentile

61%

Versus all other CVEs

30-day change

Increase +0.03 pp

From 0.92% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

1 found
  • githubUnverified

    Netty

    Maturity: poc

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Debian2 products
Ubuntu2 products
  • netty< 1:4.0.34-1ubuntu0.1~esm1 | < 1:4.1.7-4ubuntu0.1+esm2 | < 1:4.1.45-1ubuntu0.1~esm1 | < 1:4.1.48-4+deb11u1build0.22.04.1
  • netty-3.9All versions (No fix recorded)
Io.netty1 product
  • netty-codec-http≥ 4.1.83.Final, < 4.1.86.Final
Netty1 product
  • netty≥ 4.1.86.Final, < 4.1.86.Final | ≥ 4.1.83.Final, < 4.1.83.Final* | ≥ 4.1.83, < 4.1.86

4 vendors · 6 products

References

15 links
Show all 15 references