CVE-2022-48769: efi: runtime: avoid EFIv2 runtime services on Apple x86 machines
Vulnerability summary
CVE-2022-48769 is a medium (CVSS 5.5) vulnerability in linux. EPSS estimates a 0.22% chance of exploitation in the next 30 days, higher than 12.4% of scored vulnerabilities.
Not severe (CVSS 5.5, local access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 8 · Related 8Timeline
- 20-06-2024PublishedVulnerability first disclosed.
- 23-05-2026Last modifiedVulnerability information updated.
Description
In the Linux kernel, the following vulnerability has been resolved: efi: runtime: avoid EFIv2 runtime services on Apple x86 machines Aditya reports [0] that his recent MacbookPro crashes in the firmware when using the variable services at runtime. The culprit appears to be a call to QueryVariableInfo(), which we did not use to call on Apple x86 machines in the past as they only upgraded from EFI v1.10 to EFI v2.40 firmware fairly recently, and QueryVariableInfo() (along with UpdateCapsule() et al) was added in EFI v2.00. The only runtime service introduced in EFI v2.00 that we actually use in Linux is QueryVariableInfo(), as the capsule based ones are optional, generally not used at runtime (all the LVFS/fwupd firmware update infrastructure uses helper EFI programs that invoke capsule update at boot time, not runtime), and not implemented by Apple machines in the first place. QueryVariableInfo() is used to 'safely' set variables, i.e., only when there is enough space. This prevents machines with buggy firmwares from corrupting their NVRAMs when they run out of space. Given that Apple machines have been using EFI v1.10 services only for the longest time (the EFI v2.0 spec was released in 2006, and Linux support for the newly introduced runtime services was added in 2011, but the MacbookPro12,1 released in 2015 still claims to be EFI v1.10 only), let's avoid the EFI v2.0 ones on all Apple x86 machines. [0] https://lore.kernel.org/all/6D757C75-65B1-468B-842D-10410081A8E4@live.com/
CVSS metrics
3 scores · 3 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated5.5MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- OSV · DebianEcosystem advisory · calculated5.5MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
0.22%
Chance of exploitation in the next 30 days
Percentile
12%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.22% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeNo weakness data has been published for this record.
Affected systems
Known conditions: local access, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Ubuntu91 products
- linuxAll versions (No fix recorded)
- linux-allwinner-5.19All versions (No fix recorded)
- linux-awsAll versions (No fix recorded)
- linux-aws-5.0All versions (No fix recorded)
- linux-aws-5.11All versions (No fix recorded)
Linux2 products
- linux≥ d6cf86d8f23253225fe2a763d627ecf7dfee9dae, < b0f1cc093bc2493ac259c53766fd2b800e085807 | ≥ d6cf86d8f23253225fe2a763d627ecf7dfee9dae, < 3df52448978802ae15dcebf66beba1029df957b4 | ≥ d6cf86d8f23253225fe2a763d627ecf7dfee9dae, < a4085859411c825c321c9b55b8a9dc5a128a6684 | ≥ d6cf86d8f23253225fe2a763d627ecf7dfee9dae, < f5390cd0b43c2e54c7cf5506c7da4a37c5cef746 | 13fcf5d1c5fe491aeb0b0f34a46d88134432edb1 | 0c9673834740afdfa7c172b1b19c6b3ec5bc3907 | 8e221a3c057d674e3c1cc4d1d8fe65ac4697104b | b3ab8b31e8b3c1ff4971bd52d0c8ebde5cfbdb97 | ≥ 3.2.32, < 3.3 | ≥ 3.4.14, < 3.5 | ≥ 3.5.7, < 3.6 | ≥ 3.6.2, < 3.7 | 3.7
- linux_kernel< 5.10.96 | ≥ 5.11, < 5.15.19 | ≥ 5.16, < 5.16.5 | 5.17:rc1
Debian1 product
- linux< 5.16.7-1
3 vendors · 94 products