CVE-2022-49804: s390: avoid using global register for current_stack_pointer
Vulnerability summary
CVE-2022-49804 is a high (CVSS 7.8) Out-of-bounds Write vulnerability in linux. EPSS estimates a 0.19% chance of exploitation in the next 30 days, higher than 9.3% of scored vulnerabilities.
Not severe (CVSS 7.8, local access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1Timeline
- 01-05-2025PublishedVulnerability first disclosed.
- 05-08-2026Last modifiedVulnerability information updated.
Description
In the Linux kernel, the following vulnerability has been resolved: s390: avoid using global register for current_stack_pointer Commit 30de14b1884b ("s390: current_stack_pointer shouldn't be a function") made current_stack_pointer a global register variable like on many other architectures. Unfortunately on s390 it uncovers old gcc bug which is fixed only since gcc-9.1 [gcc commit 3ad7fed1cc87 ("S/390: Fix PR89775. Stackpointer save/restore instructions removed")] and backported to gcc-8.4 and later. Due to this bug gcc versions prior to 8.4 generate broken code which leads to stack corruptions. Current minimal gcc version required to build the kernel is declared as 5.1. It is not possible to fix all old gcc versions, so work around this problem by avoiding using global register variable for current_stack_pointer.
CVSS metrics
4 scores · 4 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated7.8HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- OSV · DebianEcosystem advisory · calculated7.8HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- NVDNIST7.8HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
0.19%
Chance of exploitation in the next 30 days
Percentile
9%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.19% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: local access, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Ubuntu77 products
- linux-allwinner-5.19All versions (No fix recorded)
- linux-aws-5.0All versions (No fix recorded)
- linux-aws-5.11All versions (No fix recorded)
- linux-aws-5.13All versions (No fix recorded)
- linux-aws-5.19All versions (No fix recorded)
Linux2 products
- linux≥ 30de14b1884ba609fc1acfba5b40309e3a6ccefe, < a478952a8ac44e32316dc046a063a7dc34825aa6 | ≥ 30de14b1884ba609fc1acfba5b40309e3a6ccefe, < e3c11025bcd2142a61abe5806b2f86a0e78118df | 5.18
- linux_kernelEOL≥ 5.18.1, < 6.0.10 | 5.18 | 5.18:rc3 | 5.18:rc4 | 5.18:rc5 | 5.18:rc6 | 5.18:rc7 | 6.1:rc1 | 6.1:rc2 | 6.1:rc3 | 6.1:rc4 | 6.1:rc5
Debian1 product
- linux< 6.0.10-1
3 vendors · 80 products