CVE-2023-25173: containerd supplementary groups are not set up properly
Vulnerability summary
CVE-2023-25173 is a high (CVSS 7.8) Incorrect Authorization vulnerability in containerd. EPSS estimates a 0.54% chance of exploitation in the next 30 days, higher than 45.5% of scored vulnerabilities. 1 public exploit is recorded.
Not severe (CVSS 5.3, local access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 11 · Related 13Timeline
- 16-02-2023PublishedVulnerability first disclosed.
- 10-03-2025Last modifiedVulnerability information updated.
Description
containerd is an open source container runtime. A bug was found in containerd prior to versions 1.6.18 and 1.5.18 where supplementary groups are not set up properly inside a container. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. Downstream applications that use the containerd client library may be affected as well. This bug has been fixed in containerd v1.6.18 and v.1.5.18. Users should update to these versions and recreate containers to resolve this issue. Users who rely on a downstream application that uses containerd's client library should check that application for a separate advisory and instructions. As a workaround, ensure that the `"USER $USERNAME"` Dockerfile instruction is not used. Instead, set the container entrypoint to a value similar to `ENTRYPOINT ["su", "-", "user"]` to allow `su` to properly set up supplementary groups.
CVSS metrics
8 scores · 8 sources · 2 versions- CVE.orgCNA5.3MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LDiffers
- OSV · UbuntuEcosystem advisory · calculated5.3MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LDiffers
- OSV · DebianEcosystem advisory · calculated7.8HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- OSV · WolfiEcosystem advisory · calculated5.3MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LDiffers
- OSV · ChainguardEcosystem advisory · calculated5.3MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LDiffers
- OSV · AlpineEcosystem advisory · calculated7.8HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
0.54%
Chance of exploitation in the next 30 days
Percentile
46%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.54% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundExploit Reference (benthamsgaze.org)
Maturity: unknown
Weaknesses
CWE · root causeAffected systems
Known conditions: local access, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Alpine1 product
- containerd≥ 1.6.0, < 1.6.18-r0
Chainguard1 product
- ctop< 0.7.7-r13
Containerd1 product
- containerd< 1.5.18 | ≥ 1.6.0, < 1.6.18
Debian1 product
- containerd< 1.6.18~ds1-1
Github.com/containerd1 product
- containerd< 1.5.18 | ≥ 1.6.0, < 1.6.18
Linuxfoundation1 product
- containerd< 1.5.18 | ≥ 1.6.0, < 1.6.18
Opensuse1 product
- helm&distro=openSUSE Tumbleweed< 3.13.0-2.1
Ubuntu1 product
- containerd< 1.2.6-0ubuntu1~16.04.6+esm4 | < 1.6.12-0ubuntu1~18.04.1+esm1 | < 1.6.12-0ubuntu1~20.04.3 | < 1.6.12-0ubuntu1~22.04.3
Wolfi1 product
- ctop< 0.7.7-r13
9 vendors · 9 products
References
26 links- github.com/containerd/containerd/security/advisories/GHSA-hmfx-3pcx-653pX Refsource CONFIRMREPORTAdvisoryWEBMitigationVendor Advisory
- github.com/moby/moby/security/advisories/GHSA-rc4r-wh2q-q6c4X Refsource MISCAdvisoryWEBNot Applicable
- github.com/containerd/containerd/commit/133f6bb6cd827ce35a5fb279c1ead12b9d21460aX Refsource MISCFIXWEBPatch
- www.benthamsgaze.org/2022/08/22/vulnerability-in-linux-containers-investigation-and-mitigation/X Refsource MISCWEBARTICLEExploitThird Party Advisory