9.1

CVE-2023-25725: debian debian_linux

Modified
AliasesSUSE-SU-2023:0411-1UBUNTU-CVE-2023-25725USN-5869-1
Published 14-02-2023Last modified 20-03-2025

Vulnerability summary

CVE-2023-25725 is a critical (CVSS 9.1) vulnerability in debian debian_linux. EPSS estimates a 5.49% chance of exploitation in the next 30 days, higher than 92.7% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 9.1 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 5% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
9.1/10
010
Critical · v3.1 (CVE.org)
EPSS score
5.49%
0%100%
Low · +0.04 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 11 · Related 6

Timeline

  1. 14-02-2023
    PublishedVulnerability first disclosed.
  2. 20-03-2025
    Last modifiedVulnerability information updated.

Description

HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.

CVSS metrics

4 scores · 4 sources · 1 version

EPSS trend

Probability

5.49%

Chance of exploitation in the next 30 days

Percentile

93%

Versus all other CVEs

30-day change

Increase +0.04 pp

From 5.45% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Opensuse3 products
  • haproxy&distro=openSUSE Leap 15.4< 2.4.8+git0.d1f8d41e0-150400.3.10.1
  • haproxy&distro=openSUSE Leap Micro 5.3< 2.4.8+git0.d1f8d41e0-150400.3.10.1
  • haproxy&distro=openSUSE Tumbleweed< 2.7.3+git0.1065b1000-1.1
Debian2 products
  • haproxy< 1.8.19-1+deb10u4 | < 2.6.8-2
  • debian_linuxEOL10.0 | 11.0
Suse2 products
  • haproxy&distro=SUSE Linux Enterprise High Availability Extension 15 SP4< 2.4.8+git0.d1f8d41e0-150400.3.10.1
  • haproxy&distro=SUSE Linux Enterprise Micro 5.3< 2.4.8+git0.d1f8d41e0-150400.3.10.1
Haproxy1 product
  • haproxy< 2.0.31 | ≥ 2.1.0, < 2.2.29 | ≥ 2.3.0, < 2.4.22 | ≥ 2.5.0, < 2.5.12 | ≥ 2.6.0, < 2.6.9 | ≥ 2.7.0, < 2.7.3
Ubuntu1 product
  • haproxy< 1.8.8-1ubuntu0.13 | < 2.0.29-0ubuntu1.3 | < 2.4.18-0ubuntu1.2 | < 1.6.3-1ubuntu0.3+esm2

5 vendors · 9 products

References

16 links
Show all 16 references