CVE-2023-28110: JumpServer Koko vulnerable to Command Injection for Kubernetes Connection
Vulnerability summary
CVE-2023-28110 is a critical (CVSS 9.9) vulnerability in fit2cloud jumpserver. EPSS estimates a 0.85% chance of exploitation in the next 30 days, higher than 58.1% of scored vulnerabilities. 1 public exploit is recorded.
Not severe (CVSS 5.7, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 16-03-2023PublishedVulnerability first disclosed.
- 25-02-2025Last modifiedVulnerability information updated.
Description
Jumpserver is a popular open source bastion host, and Koko is a Jumpserver component that is the Go version of coco, refactoring coco's SSH/SFTP service and Web Terminal service. Prior to version 2.28.8, using illegal tokens to connect to a Kubernetes cluster through Koko can result in the execution of dangerous commands that may disrupt the Koko container environment and affect normal usage. The vulnerability has been fixed in v2.28.8.
CVSS metrics
2 scores · 2 sources · 1 version- CVE.orgCNA5.7MediumCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:HDiffers
EPSS trend
Probability
0.85%
Chance of exploitation in the next 30 days
Percentile
58%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.85% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundJumpserver
Maturity: poc
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, administrative account, user interaction (CVSS vector). Other conditions: not stated in public data.
Fit2cloud2 products
- jumpserver< 2.28.8
- kokona
Jumpserver1 product
- jumpserver< 2.28.8
2 vendors · 3 products
References
2 links- github.com/jumpserver/jumpserver/security/advisories/GHSA-6x5p-jm59-jh29X Refsource CONFIRMExploitVendor Advisory