CVE-2023-36826: Sentry vulnerable to improper authorization on debug and artifact file downloads
Vulnerability summary
CVE-2023-36826 is a high (CVSS 7.7) Improper Authorization vulnerability in getsentry sentry. EPSS estimates a 0.63% chance of exploitation in the next 30 days, higher than 50.4% of scored vulnerabilities.
Not severe (CVSS 7.7, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 25-07-2023PublishedVulnerability first disclosed.
- 03-10-2024Last modifiedVulnerability information updated.
Description
Sentry is an error tracking and performance monitoring platform. Starting in version 8.21.0 and prior to version 23.5.2, an authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project. A patch was issued in version 23.5.2 to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher.
CVSS metrics
3 scores · 3 sources · 1 version- OSV · PypiEcosystem advisory · calculated6.5MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NDiffers
- NVDNIST6.5MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NDiffers
EPSS trend
Probability
0.63%
Chance of exploitation in the next 30 days
Percentile
50%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.63% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-285Improper AuthorizationThe product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action.
- CWE-863Incorrect AuthorizationThe product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
Affected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Getsentry1 product
- sentry≥ 8.21.0, < 23.5.2
PyPI1 product
- sentry< e932b15435bf36239431eaa3790a6bcfa47046a9 | ≥ 8.21.0, < 23.5.2
Sentry1 product
- sentry≥ 8.21.0, < 23.5.2
3 vendors · 3 products
References
6 links- github.com/getsentry/sentry/security/advisories/GHSA-m4hc-m2v6-hfw8X Refsource CONFIRMWEBAdvisoryVendor Advisory
- github.com/getsentry/sentry/commit/e932b15435bf36239431eaa3790a6bcfa47046a9X Refsource MISCWEBFIXPatch
- github.com/getsentry/sentryPACKAGE