CVE-2023-39531: Sentry vulnerable to incorrect credential validation on OAuth token requests
Vulnerability summary
CVE-2023-39531 is a medium (CVSS 6.8) Improper Authentication vulnerability in getsentry sentry. EPSS estimates a 0.36% chance of exploitation in the next 30 days, higher than 29.3% of scored vulnerabilities.
Not severe (CVSS 6.5, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 09-08-2023PublishedVulnerability first disclosed.
- 03-10-2024Last modifiedVulnerability information updated.
Description
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.
CVSS metrics
3 scores · 3 sources · 1 version- CVE.orgCNA6.5MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:NDiffers
- OSV · PypiEcosystem advisory · calculated6.5MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:NDiffers
EPSS trend
Probability
0.36%
Chance of exploitation in the next 30 days
Percentile
29%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.36% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.
Getsentry1 product
- sentry≥ 10.0.0, < 23.7.2
PyPI1 product
- sentry≥ 10.0.0, < 23.7.2
Sentry1 product
- sentry≥ 10.0.0, < 23.7.2
3 vendors · 3 products
References
5 links- github.com/getsentry/sentry/security/advisories/GHSA-hgj4-h2x3-rfx4X Refsource CONFIRMWEBVendor Advisory
- github.com/getsentry/sentryPACKAGE
- pypi.org/project/sentryPACKAGE