CVE-2023-40175: Inconsistent Interpretation of HTTP Requests in puma
Vulnerability summary
CVE-2023-40175 is a critical (CVSS 9.8) vulnerability in puma. EPSS estimates a 0.85% chance of exploitation in the next 30 days, higher than 58.1% of scored vulnerabilities.
Severe, CVSS 7.3 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 4 · Related 3Timeline
- 18-08-2023PublishedVulnerability first disclosed.
- 07-10-2024Last modifiedVulnerability information updated.
Description
Puma is a Ruby/Rack web server built for parallelism. Prior to versions 6.3.1 and 5.6.7, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies and zero-length Content-Length headers in a way that allowed HTTP request smuggling. Severity of this issue is highly dependent on the nature of the web site using puma is. This could be caused by either incorrect parsing of trailing fields in chunked transfer encoding bodies or by parsing of blank/zero-length Content-Length headers. Both issues have been addressed and this vulnerability has been fixed in versions 6.3.1 and 5.6.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS metrics
5 scores · 5 sources · 1 version- CVE.orgCNA7.3HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LDiffers
- OSV · UbuntuEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · DebianEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · RubygemsEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
0.85%
Chance of exploitation in the next 30 days
Percentile
58%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.85% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Suse5 products
- rubygem-puma&distro=SUSE Linux Enterprise High Availability Extension 15 SP1< 4.3.12-150000.3.12.1
- rubygem-puma&distro=SUSE Linux Enterprise High Availability Extension 15 SP2< 4.3.12-150000.3.12.1
- rubygem-puma&distro=SUSE Linux Enterprise High Availability Extension 15 SP3< 4.3.12-150000.3.12.1
- rubygem-puma&distro=SUSE Linux Enterprise High Availability Extension 15 SP4< 4.3.12-150000.3.12.1
- rubygem-puma&distro=SUSE Linux Enterprise High Availability Extension 15 SP5< 4.3.12-150000.3.12.1
Opensuse2 products
- rubygem-puma&distro=openSUSE Leap 15.4< 4.3.12-150000.3.12.1
- rubygem-puma&distro=openSUSE Leap 15.5< 4.3.12-150000.3.12.1
Debian1 product
- puma< 5.6.5-3+deb12u1 | < 5.6.7-1
Puma1 product
- puma< 5.6.7 | ≥ 6.0.0, < 6.3.1
RubyGems1 product
- puma< 5.6.7 | ≥ 6.0.0, < 6.3.1
Ubuntu1 product
- puma< 3.12.4-1ubuntu2+esm1 | < 5.5.2-2ubuntu2+esm1 | < 5.6.5-4ubuntu2
6 vendors · 11 products
References
17 links- github.com/puma/puma/security/advisories/GHSA-68xg-gqqm-vgj8X Refsource CONFIRMREPORTWEBVendor Advisory
Show all 17 references
- github.com/puma/pumaPACKAGE