CVE-2023-42818: SSH public key login without private key challenge if mfa is enabled in jumpserver
Vulnerability summary
CVE-2023-42818 is a critical (CVSS 9.8) Improper Authentication vulnerability in fit2cloud jumpserver. EPSS estimates a 0.68% chance of exploitation in the next 30 days, higher than 52.2% of scored vulnerabilities. 1 public exploit is recorded.
Not severe (CVSS 5.4, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1 · Related 1Timeline
- 27-09-2023PublishedVulnerability first disclosed.
- 25-03-2025Last modifiedVulnerability information updated.
Description
JumpServer is an open source bastion host. When users enable MFA and use a public key for authentication, the Koko SSH server does not verify the corresponding SSH private key. An attacker could exploit a vulnerability by utilizing a disclosed public key to attempt brute-force authentication against the SSH service This issue has been patched in versions 3.6.5 and 3.5.6. Users are advised to upgrade. There are no known workarounds for this issue.
CVSS metrics
2 scores · 2 sources · 1 version- CVE.orgCNA5.4MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:LDiffers
EPSS trend
Probability
0.68%
Chance of exploitation in the next 30 days
Percentile
52%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.68% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundJumpserver
Maturity: poc
Weaknesses
CWE · root cause- CWE-287Improper AuthenticationWhen an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
- CWE-307Improper Restriction of Excessive Authentication AttemptsThe product does not implement sufficient measures to prevent multiple failed authentication attempts within a short time frame.
Affected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Github.com/jumpserver2 products
- jumpserver≥ 3.6.0+incompatible, < 3.6.5+incompatible
- kokoAll versions (No fix recorded)
Fit2cloud1 product
- jumpserver< 3.5.6 | ≥ 3.6.0, < 3.6.5
Jumpserver1 product
- jumpserver≥ 3.6.0, < 3.6.5 | < 3.5.6
3 vendors · 4 products
References
3 links- github.com/jumpserver/jumpserver/security/advisories/GHSA-jv3c-27cv-w8jvX Refsource CONFIRMWEBExploitVendor Advisory