CVE-2023-43622: Apache HTTP Server: DoS in HTTP/2 with initial windows size 0
Vulnerability summary
CVE-2023-43622 is a high (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in apache software foundation apache http server. EPSS estimates a 68.82% chance of exploitation in the next 30 days, higher than 99.3% of scored vulnerabilities.
Severe, CVSS 7.5 (NVD); no exploitation reported by the 5 checked sources; EPSS 69% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 5 · Related 2Timeline
- 23-10-2023PublishedVulnerability first disclosed.
- 13-02-2025Last modifiedVulnerability information updated.
Description
An attacker, opening a HTTP/2 connection with an initial window size of 0, was able to block handling of that connection indefinitely in Apache HTTP Server. This could be used to exhaust worker resources in the server, similar to the well known "slow loris" attack pattern. This has been fixed in version 2.4.58, so that such connection are terminated properly after the configured connection timeout. This issue affects Apache HTTP Server: from 2.4.55 through 2.4.57. Users are recommended to upgrade to version 2.4.58, which fixes the issue.
CVSS metrics
4 scores · 4 sources · 1 version- OSV · AlpineEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
68.82%
Chance of exploitation in the next 30 days
Percentile
99%
Versus all other CVEs
30-day change
Decrease -1.78 pp
From 70.59% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Alpine1 product
- apache2< 2.4.58-r0
Apache1 product
- http_server≥ 2.4.55, < 2.4.58
Apache software foundation1 product
- apache http server≥ 2.4.55, ≤ 2.4.57
Debian1 product
- apache2< 2.4.59-1~deb12u1 | < 2.4.58-1
Ubuntu1 product
- apache2< 2.4.41-4ubuntu3.14 | < 2.4.52-1ubuntu4.6
5 vendors · 5 products
References
10 links- httpd.apache.org/security/vulnerabilities_24.htmlVendor Advisory
- security.netapp.com/advisory/ntap-20231027-0011/Third Party Advisory