CVE-2023-49083: cryptography vulnerable to NULL-dereference when loading PKCS7 certificates
Vulnerability summary
CVE-2023-49083 is a high (CVSS 7.5) NULL Pointer Dereference vulnerability in cryptography.io cryptography. EPSS estimates a 0.98% chance of exploitation in the next 30 days, higher than 62.3% of scored vulnerabilities. 1 public exploit is recorded.
Not severe (CVSS 5.9, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 7 · Related 4Timeline
- 29-11-2023PublishedVulnerability first disclosed.
- 18-12-2025Last modifiedVulnerability information updated.
Description
cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Calling `load_pem_pkcs7_certificates` or `load_der_pkcs7_certificates` could lead to a NULL-pointer dereference and segfault. Exploitation of this vulnerability poses a serious risk of Denial of Service (DoS) for any application attempting to deserialize a PKCS7 blob/certificate. The consequences extend to potential disruptions in system availability and stability. This vulnerability has been patched in version 41.0.6.
CVSS metrics
8 scores · 8 sources · 1 version- CVE.orgCNA5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HDiffers
- OSV · PypiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · Red hatEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · UbuntuEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HDiffers
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · WolfiEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HDiffers
- OSV · ChainguardEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HDiffers
EPSS trend
Probability
0.98%
Chance of exploitation in the next 30 days
Percentile
62%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.98% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundCryptography
Maturity: poc
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Suse10 products
- python-cryptography&distro=SUSE Linux Enterprise Micro 5.1< 3.3.2-150200.22.1
- python-cryptography&distro=SUSE Linux Enterprise Micro 5.2< 3.3.2-150200.22.1
- python-cryptography&distro=SUSE Linux Enterprise Module for Public Cloud 15 SP1< 3.3.2-150100.7.18.1
- python-cryptography&distro=SUSE Linux Enterprise Module for Python 3 15 SP4< 41.0.3-150400.16.12.1
- python-cryptography&distro=SUSE Linux Enterprise Module for Python 3 15 SP5< 41.0.3-150400.16.12.1
Opensuse7 products
- python-cryptography&distro=openSUSE Leap 15.4< 41.0.3-150400.16.12.1
- python-cryptography&distro=openSUSE Leap 15.5< 41.0.3-150400.16.12.1
- python-cryptography&distro=openSUSE Tumbleweed< 41.0.7-1.1
- python3-cryptography&distro=openSUSE Leap 15.4< 3.3.2-150400.23.1
- python3-cryptography&distro=openSUSE Leap 15.5< 3.3.2-150400.23.1
Redhat7 products
- python-cryptography< 0:3.2.1-4.el8_4.1 | < 0:3.2.1-6.el8_8 | < 0:36.0.1-2.el9_2.1 | < 0:36.0.1-1.el9_0.1 | < 0:36.0.1-4.el9_4.1 | < 0:3.2.1-5.1.el8_6.1 | < 0:3.2.1-8.el8_10 | < 0:36.0.1-5.el9_6
- python-cryptography-debugsource< 0:3.2.1-4.el8_4.1 | < 0:3.2.1-6.el8_8 | < 0:36.0.1-2.el9_2.1 | < 0:36.0.1-1.el9_0.1 | < 0:36.0.1-4.el9_4.1 | < 0:3.2.1-5.1.el8_6.1 | < 0:3.2.1-8.el8_10 | < 0:36.0.1-5.el9_6
- python3-cryptography< 0:3.2.1-4.el8_4.1 | < 0:3.2.1-6.el8_8 | < 0:36.0.1-2.el9_2.1 | < 0:36.0.1-1.el9_0.1 | < 0:36.0.1-4.el9_4.1 | < 0:3.2.1-5.1.el8_6.1 | < 0:3.2.1-8.el8_10 | < 0:36.0.1-5.el9_6
- python3-cryptography-debuginfo< 0:3.2.1-4.el8_4.1 | < 0:3.2.1-6.el8_8 | < 0:36.0.1-2.el9_2.1 | < 0:36.0.1-1.el9_0.1 | < 0:36.0.1-4.el9_4.1 | < 0:3.2.1-5.1.el8_6.1 | < 0:3.2.1-8.el8_10 | < 0:36.0.1-5.el9_6
- python3.11-cryptography< 0:37.0.2-5.el8_8.1 | < 0:37.0.2-6.el9 | < 0:37.0.2-6.el8
Chainguard3 products
- mitmproxy< 12.2.1-r0
- py3-cassandra-medusa< 0.19.1-r1
- py3-cassandra-medusa-compat< 0.19.1-r1
Wolfi3 products
- mitmproxy< 12.2.1-r0
- py3-cassandra-medusa< 0.19.1-r1
- py3-cassandra-medusa-compat< 0.19.1-r1
Cryptography.io1 product
- cryptography≥ 3.1, < 41.0.6
Debian1 product
- python-cryptography< 38.0.4-3+deb12u1 | < 41.0.7-1
Pyca1 product
- cryptography≥ 3.1, < 41.0.6
PyPI1 product
- cryptography< f09c261ca10a31fe41b1262306db7f8f1da0e48a | ≥ 3.1, < 41.0.6
Ubuntu1 product
- python-cryptography< 3.4.8-1ubuntu2.1
10 vendors · 35 products
References
49 links- github.com/pyca/cryptography/security/advisories/GHSA-jfhm-5ghh-2f97X Refsource CONFIRMWEBAdvisoryARTICLEREPORTExploitVendor Advisory
- github.com/pyca/cryptography/commit/f09c261ca10a31fe41b1262306db7f8f1da0e48aX Refsource MISCWEBFIXARTICLEPatch
Show all 49 references
- github.com/pyca/cryptographyPACKAGE