6.5

CVE-2023-49295: quic-go's path validation mechanism can cause denial of service

Modified
AliasesRHSA-2024:0855UBUNTU-CVE-2023-49295DEBIAN-CVE-2023-49295
Published 10-01-2024Last modified 17-06-2025

Vulnerability summary

CVE-2023-49295 is a medium (CVSS 6.5) Uncontrolled Resource Consumption vulnerability in quic-go_project quic-go. EPSS estimates a 1.20% chance of exploitation in the next 30 days, higher than 68.3% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 6.4, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
6.5/10
010
Medium · v3.1 (NVD)
EPSS score
1.20%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 1 · Related 6

Timeline

  1. 10-01-2024
    PublishedVulnerability first disclosed.
  2. 17-06-2025
    Last modifiedVulnerability information updated.

Description

quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.

CVSS metrics

8 scores · 8 sources · 1 version

EPSS trend

Probability

1.20%

Chance of exploitation in the next 30 days

Percentile

68%

Versus all other CVEs

30-day change

No change 0.00 pp

From 1.20% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard4 products
  • caddy< 2.7.6-r2
  • caddy-man< 2.7.6-r2
  • caddy-src< 2.7.6-r2
  • frp< 0.53.2-r1
Wolfi4 products
  • caddy< 2.7.6-r2
  • caddy-man< 2.7.6-r2
  • caddy-src< 2.7.6-r2
  • frp< 0.53.2-r1
Debian1 product
  • golang-github-lucas-clemente-quic-goAll versions (No fix recorded) | < 0.38.2-1
Github.com/quic-go1 product
  • quic-go≥ 0.39.0, < 0.39.4 | ≥ 0.38.0, < 0.38.2 | < 0.37.7 | ≥ 0.40.0, < 0.40.1
Opensuse1 product
  • kubo&distro=openSUSE Tumbleweed< 0.32.1-1.1
Quic-go1 product
  • quic-go= 0.40.0 | ≥ 0.39.0, < 0.39.4 | ≥ 0.38.0, < 0.38.2 | < 0.37.7
Quic-go_project1 product
  • quic-go< 0.37.7 | ≥ 0.38.0, < 0.38.2 | ≥ 0.39.0, < 0.39.4 | 0.40.0
Redhat1 product
  • receptor< 0:1.4.4-1.el8ap | < 0:1.4.4-1.el9ap
Ubuntu1 product
  • golang-github-lucas-clemente-quic-goAll versions (No fix recorded)

9 vendors · 15 products

References

27 links
Show all 27 references