CVE-2024-23653: BuildKit interactive containers API does not validate entitlements check
Vulnerability summary
CVE-2024-23653 is a critical (CVSS 9.8) Incorrect Authorization vulnerability in moby buildkit. EPSS estimates a 3.45% chance of exploitation in the next 30 days, higher than 89% of scored vulnerabilities.
Severe, CVSS 9.8 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 3% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 14 · Related 28Timeline
- 31-01-2024PublishedVulnerability first disclosed.
- 23-08-2024Last modifiedVulnerability information updated.
Description
BuildKit is a toolkit for converting source code to build artifacts in an efficient, expressive and repeatable manner. In addition to running containers as build steps, BuildKit also provides APIs for running interactive containers based on built images. It was possible to use these APIs to ask BuildKit to run a container with elevated privileges. Normally, running such containers is only allowed if special `security.insecure` entitlement is enabled both by buildkitd configuration and allowed by the user initializing the build request. The issue has been fixed in v0.12.5 . Avoid using BuildKit frontends from untrusted sources.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · WolfiEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · GoEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · ChainguardEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVDNIST9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · AlpineEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
3.45%
Chance of exploitation in the next 30 days
Percentile
89%
Versus all other CVEs
30-day change
No change 0.00 pp
From 3.45% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard21 products
- buildkitd< 0.12.5-r0
- conftest< 0.49.0-r1
- conftest-fips< 0.48.0-r2
- docker< 25.0.2-r0
- docker-config-mirror-gcr< 25.0.2-r0
Wolfi20 products
- buildkitd< 0.12.5-r0
- conftest< 0.49.0-r1
- docker< 25.0.2-r0
- docker-config-mirror-gcr< 25.0.2-r0
- docker-dind< 25.0.2-r0
Alpine4 products
- buildkit< 0.12.5-r0
- docker< 25.0.2-r0
- podman< 4.9.2-r0
- singularity< 4.1.1-r0
Opensuse2 products
- buildkit&distro=openSUSE Tumbleweed< 0.12.5-2.1
- docker-stable&distro=openSUSE Tumbleweed< 24.0.9_ce-4.1
Ubuntu2 products
- docker.ioAll versions (No fix recorded)
- docker.io-app< 26.1.3-0ubuntu1~20.04.1+esm1 | < 27.5.1-0ubuntu3~22.04.2 | < 27.5.1-0ubuntu3~24.04.2
Github.com/moby1 product
- buildkit< 0.12.5
Moby1 product
- buildkit< 0.12.5
Mobyproject1 product
- buildkit< 0.12.5
8 vendors · 52 products
References
13 links- github.com/moby/buildkit/security/advisories/GHSA-wr6v-9f75-vh2gX Refsource CONFIRMREPORTAdvisoryWEBVendor Advisory
- github.com/moby/buildkitPACKAGE
Show all 13 references
- lists.opensuse.org/archives/…Advisory